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Notice
The material in this document is provided “as is,” and is subject to change without notice in future 
editions.

Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either 
express or implied with regard to this manual and to any of the Agilent products to which it 
pertains, including but not limited to the implied warranties of merchantability and fitness for a 
particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in 
connection with the furnishing, use, or performance of this document or any of the Agilent products 
to which it pertains. Should Agilent have a written contract with the User and should any of the 
contract terms conflict with these terms, the contract terms shall control.
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1 Signal Generator Overview

In the following sections, this chapter describes the models, options, and features available for 
Agilent E8663B signal generator. The modes of operation, front panel user interface, as well as front 
and rear panel connectors are also described.

• “E8663B Signal Generator Features” on page 1

• “Options” on page 3

• “Firmware Upgrades” on page 3

• “Modes of Operation” on page 4

• “Front Panel” on page 5

• “Front Panel Display” on page 11

• “Rear Panel” on page 15

NOTE For more information about the signal generator, such as data sheets, configuration guides, 
application notes, frequently asked questions, technical support, software and more, visit the 
Agilent web page at http://www.agilent.com/find/e8663b.

E8663B Signal Generator Features

The E8663B includes the following standard features:

• ultra low phase noise

• step attenuator

• pulse modulation

• internal pulse generator

• external modulation inputs

• selectable pulse modes: internal square, internal free- run, internal triggered, internal doublet, 
internal gated, and external pulse; internal triggered, internal doublet, and internal gated 
require an external trigger source

• adjustable pulse rate, pulse period, pulse delay, and pulse width (150 ns minimum)

• selectable external pulse triggering: positive or negative
Agilent E8663B Analog Signal Generator User’s Guide 1



Signal Generator Overview
E8663B Signal Generator Features
• AM, FM, phase modulation, and LF output

• open- loop or closed- loop AM

• dc- synthesized FM to 10 MHz rates; maximum deviation depends on the carrier frequency

• external modulation inputs for AM, FM, and ΦM

• simultaneous modulation configurations (except: FM with ΦM or Linear AM with 
Exponential AM)

• dual function generators that include the following:

— 50- ohm low- frequency output, 0 to 3 Vp, available through the LF output

— selectable waveforms: sine, dual- sine, swept- sine, triangle, positive ramp, negative ramp, 
square, uniform noise, Gaussian noise, and dc

— adjustable frequency modulation rates

— selectable triggering in list and step sweep modes: free run (auto), trigger key (single), bus 
(remote), and external

• CW output from 100 kHz to the highest operating frequency, depending on the option

• frequency resolution to 0.001 Hz

• list and step sweep of frequency and amplitude, with multiple trigger sources

• user flatness correction

• external diode detector leveling

• automatic leveling control (ALC) on and off modes; power calibration in ALC- off mode is 
available, even without power search

• 10 MHz reference oscillator with external output

• RS- 232, GPIB, and 10Base- T LAN I/O interfaces

• Type- N female RF output connector

The E8663B also offers the following optional features:

Option 503—frequency range from 100 kHz to 3.2 GHz

Option 509—frequency range from 100 kHz to 9.0 GHz

Option UNW—narrow pulse modulation

• in addition to the standard pulse modulation features, generate narrow pulses (20 ns 
minimum) across the operational frequency band of the signal generator

Option 1EM—moves all front panel connectors to the rear panel

Option 1EZ—extended support life
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Options
E8663B signal generators have hardware, firmware, software, and documentation options. The Data 
Sheet shipped with your signal generator provides an overview of available options. For more 
information, visit the Agilent E8663B web page at http://www.agilent.com/find/e8663b and click the 
Options tab.

Firmware Upgrades
You can upgrade the firmware in your signal generator whenever new firmware is released. New 
firmware releases, which can be downloaded from the Agilent website, may contain signal generator 
features and functionality not available in previous firmware releases.

To determine about the availability of new signal generator firmware, visit the Signal Generator 
Firmware Upgrade Center web page at http://www.agilent.com/find/upgradeassistant, or call the 
number listed at http://www.agilent.com/find/assist.

To Upgrade Firmware

The following procedure shows you how to download new firmware to your signal generator using a 
LAN connection and a PC. For information on equipment requirements and alternate methods of 
downloading firmware, such as GPIB, refer to the Firmware Upgrade Guide, which can be accessed 
at http://www.agilent.com/find/upgradeassistant. 

1. Note the IP address of your signal generator. To view the IP address on the signal generator, 
press Utility > GPIB/RS-232 LAN > LAN Setup.

2. Use an internet browser to visit http://www.agilent.com/find/upgradeassistant.

3. Scroll down to the “Documents and Downloads” table and click the link in the “Latest Firmware 
Revision” column for the E8663B.

4. In the File Download window, select Run.

5. In the Welcome window, click Next and follow the on- screen instructions. The firmware files 
download to the PC.

6. In the “Documents and Downloads” table, click the link in the “Upgrade Assistant Software” 
column for the E8663B to download the PSG/ESG Upgrade Assistant.

7. In the File Download window, select Run.

8. In the Welcome window, click OK and follow the on- screen instructions.

9. At the desktop shortcut prompt, click Yes.

10. Once the utility downloads, close the browser and double- click the PSG/ESG Upgrade Assistant icon on 
the desktop.
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11. In the Upgrade Assistant, set the connection type you wish to use to download the firmware, and 
the parameters for the type of connection selected. For LAN, enter the instrument’s IP address, 
which you recorded in step 1.

NOTE If the signal generator’s dynamic host configuration protocol (DHCP) is enabled, the network 
assigns the instrument an IP address at power on. Because of this, when DHCP is enabled 
the IP address may be different each time you turn on the instrument. DHCP does not affect 
the hostname.

12. Click Browse, and double- click the firmware revision to upgrade your signal generator.

13. In the Upgrade Assistant, click Next.

14. Once connection to the instrument is verified, click Next and follow the on- screen prompts.

NOTE Once the download starts, it cannot be aborted.

NOTE When the User Attention message appears, you must first cycle the instrument’s power, then 
click OK.

When the upgrade completes, the Upgrade Assistant displays a summary.

15. Click OK and close the Upgrade Assistant.

Modes of Operation
Depending on the model and installed options, the signal generator provides several modes of 
operation: continuous wave (CW), swept signal, and analog modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to 
a single frequency and power level.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog 
modulation types available are standard pulse, AM, FM, and ΦM. Narrow pulse modulation capability 
is available with Option UNW.
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Front Panel
This section describes each item on the signal generator front panel. Figure 1- 1 shows an E8663B 
front panel.

Figure 1-1 Front Panel Diagram

1. Display

The LCD screen provides information on the current function. Information can include status 
indicators, frequency and amplitude settings, and error messages. Softkey labels are located on the 
right- hand side of the display. For more detail on the front panel display, see “Front Panel Display” 
on page 11.

1. Display 9. MENUS 17. Numeric Keypad 25. Return 
2. Softkeys 10. Help 18. RF OUTPUT 26. Contrast Decrease 
3. Knob 11. EXT 1 INPUT 19. SYNC OUT 27. Contrast Increase 

4. Amplitude 12. EXT 2 INPUT 20. VIDEO OUT 28. Local 
5. Frequency 13. LF OUTPUT 21. Incr Set 29. Preset 
6. Save 14. Mod On/Off  22. GATE/ PULSE/ TRIGGER INPUT 30. Line Power LED 

7. Recall 15. ALC INPUT 23. Arrow Keys 31. LINE 
8. Trigger 16. RF On/Off 24. Hold 32. Standby LED 
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2. Softkeys

Softkeys activate the displayed function to the left of each key.

3. Knob

Use the knob to increase or decrease a numeric value, change a highlighted digit or character, or step 
through lists or select items in a row.

4. Amplitude

Pressing this hardkey makes amplitude the active function. You can change the output amplitude or 
use the menus to configure amplitude attributes such as power search, user flatness, and leveling 
mode.

5. Frequency

Pressing this hardkey makes frequency the active function. You can change the output frequency or 
use the menus to configure frequency attributes such as frequency multiplier, offset, and reference.

6. Save

Pressing this hardkey accesses a menu of choices that enable you to save data in the instrument state 
register. The instrument state register is a section of memory divided into 10 sequences (numbered 0 
through 9), each containing 100 registers (numbered 00 through 99). It is used to store and recall 
frequency, amplitude, and modulation settings.

The Save hardkey provides a quick alternative to reconfiguring the signal generator through the front 
panel or SCPI commands when switching between different signal configurations. Once an instrument 
state has been saved, all of the frequency, amplitude, and modulation settings can be recalled with 
the Recall hardkey. For more information on saving and recalling instrument states, refer to “Using the 
Instrument State Registers” on page 34.

7. Recall

Restores an instrument state saved in a memory register. To recall an instrument state, press Recall 
and enter the desired sequence number and register number. To save a state, use the Save hardkey. 
For more information on saving and recalling instrument states, refer to “Using the Instrument State 
Registers” on page 34.

8. Trigger

Initiates an immediate trigger event for a function such as a list or step. Before this hardkey can be 
used to initiate a trigger event, the trigger mode must be set to Trigger Key. For example: press the 
Sweep/List hardkey, then one of the following sequences of softkeys:

• More (1 of 2) > Sweep Trigger > Trigger Key 
• More (1 of 2) > Point Trigger > Trigger Key
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9. MENUS

These keys open softkey menus for configuring various functions. For descriptions, see the E8663B 
Signal Generator Key Reference.

NOTE Some menus are optional. Refer to “Options” on page 3 for more information.

10. Help

Pressing this hardkey accesses a short description of any hardkey or softkey and, in most cases, a 
listing of related remote- operation SCPI commands. There are two help modes available on the signal 
generator: single and continuous. The single mode is the factory preset condition. Toggle between 
single and continuous mode by pressing Utility > Instrument Info/Help Mode > Help Mode Single Cont.

• In single mode, help text is provided for the next key you press without activating the key’s 
function. Any key pressed afterward exits the help mode and its function is activated.

• In continuous mode, help text is provided for each subsequent key press until you press the Help 
hardkey again or change to single mode. In addition, each key is active, meaning that the key 
function is executed (except for the Preset key).

11. EXT 1 INPUT

This female BNC input connector accepts a ±1 Vp signal for AM, FM, and ΦM. For these modulations, 
±1 Vp produces the indicated deviation or depth. When ac- coupled inputs are selected for AM, FM, or 
ΦM and the peak input voltage differs from 1 Vp by more than 3 percent, the HI/LO display 
annunciators light. The input impedance is selectable as either 50 or 600 ohms; the damage levels are 
5 Vrms and 10 Vp. On signal generators with Option 1EM, this connector is relocated to the rear 
panel.

12. EXT 2 INPUT

This female BNC input connector accepts a ±1 Vp signal for AM, FM, and ΦM. With AM, FM, or ΦM, 
±1 Vp produces the indicated deviation or depth. When ac- coupled inputs are selected for AM, FM, or 
ΦM and the peak input voltage differs from 1 Vp by more than 3 percent, the HI/LO annunciators 
light on the display. The input impedance is selectable as either 50 or 600 ohms and damage levels 
are 5 Vrms and 10 Vp. On signal generators with Option 1EM, this input is relocated to the rear 
panel.

Table 1-1 Hardkeys in Front Panel MENUS Group

E8663B Signal 
Generator

AM
Sweep/List
FM/ΦM
Utility
Pulse
LF Out
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13. LF OUTPUT

This female BNC output connector outputs modulation signals generated by the low frequency (LF) 
source function generator. This output is capable of driving 3Vp (nominal) into a 50- ohm load. On 
signal generators with Option 1EM, this output is relocated to the rear panel.

14. Mod On/Off

This hardkey enables or disables all active modulation formats (AM, FM, ΦM, Pulse, or I/Q) applied 
to the output carrier signal available through the RF Output connector. This hardkey does not set up 
or activate an AM, FM, ΦM, Pulse, or I/Q format; each modulation format must still be set up and 
activated (for example, AM > AM On) or nothing is applied to the output carrier signal when the Mod 
On/Off hardkey is enabled. The MOD ON/OFF annunciator indicates whether active modulation formats 
have been enabled or disabled with the Mod On/Off hardkey.

15. ALC INPUT

This female BNC input connector is used for negative external detector leveling. This connector 
accepts an input of −0.2 mV to −0.5 V. The nominal input impedance is 120 kohms and the damage 
level is ±15 V. On signal generators with Option 1EM, this input is relocated to the rear panel.

16. RF On/Off

Pressing this hardkey toggles the operating state of the RF signal present at the RF OUTPUT 
connector. Although you can set up and enable various frequency, power, and modulation states, the 
RF and microwave output signal is not present at the RF OUTPUT until RF On/Off is set to On. The 
RF On/Off annunciator is always visible in the display to indicate whether the RF is turned on or off.

17. Numeric Keypad

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point hardkey, and a backspace 
hardkey ( ). The backspace hardkey enables you to backspace or alternate between a positive 
and a negative value. When specifying a negative numeric value, the negative sign must be entered 
prior to entering the numeric value.

18. RF OUTPUT

This connector outputs RF and microwave signals. The nominal output impedance is 50 ohms. The 
reverse- power damage levels are 0 Vdc, 0.5 watts nominal. On signal generators with Option 1EM, 
this output is relocated on the rear panel. The connector type varies according to frequency option.

19. SYNC OUT

This female BNC output connector outputs a synchronizing TTL- compatible pulse signal that is 
nominally 50 ns wide during internal and triggered pulse modulation. The nominal source impedance 
is 50 ohms. On signal generators with Option 1EM, this output is relocated to the rear panel.
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20. VIDEO OUT

This female BNC output connector outputs a TTL- level compatible pulse signal that follows the 
output envelope in all pulse modes. The nominal source impedance is 50 ohms. On signal generators 
with Option 1EM, this output is relocated to the rear panel.

21. Incr Set

This hardkey enables you to set the increment value of the current active function. The increment 
value of the current active function appears in the active entry area of the display. Use the numeric 
keypad, arrow hardkeys, or the knob to adjust the increment value.

22. GATE/ PULSE/ TRIGGER INPUT

This female BNC input connector accepts an externally supplied pulse signal for use as a pulse or 
trigger input. With pulse modulation, +1 V is on and 0 V is off (trigger threshold of 0.5 V with a 
hysteresis of 10 percent; so 0.6 V would be on and 0.4 V would be off). The damage levels are 
±5 Vrms and 10 Vp. The nominal input impedance is 50 ohms. On signal generators with Option 1EM, 
this input is relocated to the rear panel.

23. Arrow Keys

These up and down arrow hardkeys are used to increase or decrease a numeric value, step through 
displayed lists, or to select items in a row of a displayed list. Individual digits or characters may be 
highlighted using the left and right arrow hardkeys. Once an individual digit or character is 
highlighted, its value can be changed using the up and down arrow hardkeys.

24. Hold

Pressing this hardkey blanks the softkey label area and text areas on the display. Softkeys, arrow 
hardkeys, the knob, the numeric keypad, and the Incr Set hardkey have no effect once this hardkey is 
pressed.

25. Return

Pressing this hardkey returns you to the softkey menu you were at previously. It enables you to step 
back through the menus until you reach the first menu you selected.

26. Contrast Decrease

Pressing this hardkey causes the display background to darken.

27. Contrast Increase

Pressing this hardkey causes the display background to lighten.

28. Local

Pressing this hardkey deactivates remote operation and returns the signal generator to front- panel 
control.
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29. Preset

Pressing this hardkey sets the signal generator to a known state (factory or user- defined).

30. Line Power LED

This green LED indicates when the signal generator power switch is set to the on position.

31. LINE

In the on position, this switch activates full power to the signal generator; in standby, it deactivates 
all signal generator functions. In standby, the signal generator remains connected to the line power 
and power is supplied to some internal circuits.

32. Standby LED

This yellow LED indicates when the signal generator power switch is set to the standby condition.
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Front Panel Display
Figure 1- 2 shows the various regions of the signal generator display. This section describes each 
region.

Figure 1-2 Front Panel Display Diagram

1. Active Entry Area

The current active function is shown in this area. For example, if frequency is the active function, the 

1. Active Entry Area 5. Error Message Area
2. Frequency Area 6. Text Area
3. Annunciators 7. Softkey Label Area

4. Amplitude Area
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current frequency setting will be displayed here. If the current active function has an increment value 
associated with it, that value is also displayed. 

2. Frequency Area

The current frequency setting is shown in this portion of the display. Indicators are also displayed in 
this area when the frequency offset or multiplier is used or the frequency reference mode is turned 
on.

3. Annunciators

The display annunciators show the status of some of the signal generator functions and indicate any 
error conditions. An annunciator position may be used by more than one function. This does not 
create a problem, because only one function that shares an annunciator position can be active at a 
time.

ΦM  This annunciator appears when phase modulation is on. If frequency modulation 
is on, the FM annunciator replaces ΦM.

ALC OFF  This annunciator appears when the ALC circuit is disabled. A second annunciator, 
UNLEVEL, appears in the same position if the ALC is enabled and cannot maintain 
the output level.

AM  This annunciator appears when amplitude modulation is on.

ARMED  This annunciator appears when a sweep has been initiated and the signal 
generator is waiting for the sweep trigger event.

ATTEN HOLD  This annunciator appears when the attenuator hold function is on. When this 
function is on, the attenuator is held at its current setting. 

ENVLP  This annunciator appears if a burst condition exists, such as when marker 2 is set 
to enable RF blanking in the Dual ARB format. 

ERR  This annunciator appears when an error message is in the error queue. This 
annunciator does not turn off until you either view all the error messages or 
cleared the error queue. To access error messages, press Utility > Error Info.

EXT  This annunciator appears when external leveling is on.

EXT1 LO/HI  This annunciator appears as either EXT1 LO or EXT1 HI, when the ac- coupled 
signal to the EXT 1 INPUT is <0.97 Vp or >1.03 Vp.

EXT2 LO/HI  This annunciator is displayed as either EXT2 LO or EXT2 HI. This annunciator 
appears when the ac- coupled signal to the EXT 2 INPUT is <0.97 Vp or >1.03 Vp.

EXT REF  This annunciator appears when an external frequency reference is applied.

FM  This annunciator appears when frequency modulation is turned on. If phase 
modulation is turned on, the ΦM annunciator will replace FM.
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L  This annunciator appears when the signal generator is in listener mode and is 
receiving information or commands over the RS- 232, GPIB, or VXI- 11 LAN 
interface.

MOD ON/OFF  This annunciator indicates whether active modulation formats have been enabled 
or disabled. Pressing the Mod On/Off hardkey enables or disables all active 
modulation formats (AM, FM, ΦM, Pulse, or I/Q) that are applied to the output 
carrier signal available through the RF Output connector. The Mod On/Off hardkey 
does not set up or activate an AM, FM, ΦM, Pulse, or I/Q format; each individual 
modulation format must still be set up and activated (for example, AM > AM On) or 
nothing will be applied to the output carrier signal when the Mod On/Off hardkey is 
enabled.

OVEN COLD  This annunciator appears when the temperature of the internal oven reference 
oscillator has dropped below an acceptable level. When this annunciator is on, 
frequency accuracy is degraded. This condition should occur for several minutes 
after the signal generator is first connected to line power.

PULSE  This annunciator appears when pulse modulation is on.

R  This annunciator appears when the signal generator is remotely controlled over 
the GPIB, RS- 232, or VXI- 11/Sockets LAN interface (TELNET operation does not 
activate the R annunciator). When the R annunciator is on, the front panel keys 
are disabled, except for the Local key and the line power switch. For information 
on remote operation, refer to the E8663B Signal Generator Programming Guide.

RF ON/OFF  This annunciator indicates when the RF and microwave signal is present (RF ON) 
at the RF OUTPUT, or if the RF and microwave signal is not present (RF OFF) at 
the RF OUTPUT. Either condition of this annunciator is always visible in the 
display.

S  This annunciator appears when the signal generator has generated a service 
request (SRQ) over the RS- 232, GPIB, or VXI- 11 LAN interface.

SWEEP  This annunciator appears when the signal generator is in list or step sweep mode. 
List mode is when the signal generator can jump from point to point in a list (hop 
list); the list is traversed in ascending or descending order. The list can be a 
frequency list, a power level list, or both. Step mode is when a start, stop, and 
step value (frequency or power level) are defined and the signal generator 
produces signals that start at the start value and increment by the step value 
until it reaches the stop value. 

T  This annunciator appears when the signal generator is in talker mode and is 
transmitting information over the GPIB, RS- 232, or VXI- 11 LAN interface.
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UNLEVEL  This annunciator appears when the signal generator is unable to maintain the 
correct output level. The UNLEVEL annunciator is not necessarily an indication of 
instrument failure. Unleveled conditions can occur during normal operation. A 
second annunciator, ALC OFF, will appear in the same position when the ALC 
circuit is disabled.

UNLOCK  This annunciator appears when any of the phase locked loops are unable to 
maintain phase lock. You can determine which loop is unlocked by examining the 
error messages.

4. Amplitude Area

The current output power level setting is shown in this portion of the display. Indicators are also 
displayed in this area when amplitude offset is used, amplitude reference mode is turned on, external 
leveling mode is enabled, and when user flatness is enabled.

5. Error Message Area

Abbreviated error messages are reported in this space. When multiple error messages occur, only the 
most recent message remains displayed. Reported error messages with details can be viewed by 
pressing Utility > Error Info.

6. Text Area

This text area of the display:

• shows signal generator status information, such as the modulation status, sweep lists, and file 
catalogs

• displays the tables

• enables you to perform functions such as managing information, entering information, and 
displaying or deleting files

7. Softkey Label Area

The labels in this area define the function of the softkeys located immediately to the right of the 
label. The softkey label may change depending upon the function selected.
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Rear Panel
This section describes each item on the signal generator rear panel. Figure 1- 3 shows a standard 
E8663B rear panel. Figure 1- 4 on page 16 shows an E8663B rear panel with Option 1EM. 
Option 1EM moves all front panel connectors to the real panel.

Figure 1-3 Standard Rear Panel Diagram

1. Source Module Interface 6. 10 MHz IN 11. Z- AXIS BLANK/MKRS
2. 1 GHz Output 7. AUXILIARY INTERFACE 12. SWEEP OUT

3. AC Power Receptacle 8. 10 MHz OUT 13. TRIGGER OUT
4. GPIB 9. LAN 14. TRIGGER IN
5. 10 MHz EFC 10. SWEEP OUT 15. SOURCE SETTLED
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Figure 1-4 Option 1EM Rear Panel Diagram

1. Source Module Interface 9. LAN 17. EXT 1 Input
2. 1 GHz Output 10. SWEEP OUT 18. EXT 2 Input
3. AC Power Receptacle 11. Z- AXIS BLANK/MKRS 19. LF OUT

4. GPIB 12. SWEEP OUT 20. PULSE SYNC OUT
5. 10 MHz EFC 13. TRIGGER OUT 21. PULSE VIDEO OUT
6. 10 MHz IN 14. TRIGGER IN 22. PULSE/TRIG GATE INPUT

7. AUXILIARY INTERFACE 15. SOURCE SETTLED 23. ALC INPUT
8. 10 MHz OUT 16. RF OUT
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1. Source Module Interface

Inactive.

2. 1 GHz Output

This female BNC connector provides a 1 GHz low noise frequency reference output signal.

3. AC Power Receptacle

The ac line voltage is connected here. The power cord receptacle accepts a three- pronged power cable 
that is shipped with the signal generator.

4. GPIB

This GPIB interface allows listen and talk capability with compatible IEEE 488.2 devices.

5. 10 MHz EFC

This female BNC input connector accepts an external dc voltage, ranging from −5 V to +5 V, for 
electronic frequency control (EFC) of the internal 10 MHz reference oscillator. This voltage inversely 
tunes the oscillator about its center frequency approximately −0.0025 ppm/V. The nominal input 
impedance is greater than 1 Mohms. When not in use, this connector should be shorted using the 
supplied shorting cap to assure a stable operating frequency.

6. 10 MHz IN

This female BNC connector accepts an external timebase reference input signal level of > −3 dBm. 
The reference must be 1, 2, 2.5, 5, or 10 MHz, within ±1 ppm. The signal generator detects when a 
valid reference signal is present at this connector and automatically switches from internal to 
external reference operation.

The nominal input impedance is 50 ohms with a damage level of ≥ 10 dBm.

7. AUXILIARY INTERFACE

This 9- pin D- subminiature female connector is an RS- 232 serial port that can be used for serial 
communication and Master/Slave source synchronization.

Table 1-2 Auxiliary Interface Connector

Pin Number Signal Description Signal Name

1 No Connection (default operation)/
Retrace (Master/Slave operation)

2 Receive Data RECV

3 Transmit Data XMIT

4 +5V (Default operation)/
Sweep Stop (Master/Slave operation)
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Figure 1-5

8. 10 MHz OUT

This female BNC connector outputs a nominal signal level of > +4 dBm and has an output impedance 
of 50 ohms. The accuracy is determined by the timebase used.

9. LAN

This LAN interface allows ethernet local area network communication through a 10Base- T LAN cable. 
The yellow LED on the interface illuminates when data transmission (transfer/receive) is present. The 
green LED illuminates when there is a delay in data transmission or no data transmission is present.

10. SWEEP OUT

This female BNC connector outputs a voltage proportional to the RF power or frequency sweep 
ranging from 0 V at the start of sweep and goes to +10 V (nominal) at the end of sweep, regardless 
of sweep width.

The nominal output impedance is less than 1 ohm and can drive a 2- kohm load.

11. Z-AXIS BLANK/MKRS

This female BNC connector supplies a +5 V (nominal) level during retrace and band- switch intervals 
of a step or list sweep. This signal is derived from an operational amplifier output so the load 
impedance should be greater than or equal to 5 kohms.

12. SWEEP OUT

This female BNC connector outputs a voltage proportional to the RF power or frequency sweep 
ranging from 0 V at the start of sweep and goes to +10 V (nominal) at the end of sweep, regardless 
of sweep width.

The nominal output impedance is less than 1 ohm and can drive a 2- kohm load.

5 Ground, 0V

6 No Connection

7 Request to Send RTS

8 Clear to Send CTS

9 No Connection

Table 1-2 Auxiliary Interface Connector

Pin Number Signal Description Signal Name

View looking into 
rear panel connector
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13. TRIGGER OUT

This female BNC connector, in step/list sweep mode, outputs a TTL signal that is high at the start of 
a dwell sequence or when waiting for a point trigger in manual sweep mode. The signal is low when 
the dwell is over or when a point trigger is received. When using LF Out, the output provides a 2 µs 
pulse at the start of LF sweep. The nominal impedance for this connector is less than 10 ohms.

On signal generators with Option 1EM, this output is changed from a BNC to an SMB connector.

14. TRIGGER IN

This female BNC connector accepts a 3.3V CMOS signal, which is used for point- to- point triggering in 
manual sweep mode, or in an low- frequency (LF output) or analog (AM, FM, and ΦM) external sweep 
trigger setup. Triggering can occur on either the positive or negative edge of the signal start. The 
damage level is ≤ −4 V or ≥ +10 V. The nominal input impedance for this connector is approximately 
4.2 kohms.

15. SOURCE SETTLED

This female BNC connector provides a 3- volt CMOS output trigger, indicating when the signal 
generator has settled to a new frequency or power level. A high indicates that the source has not 
settled. A low indicates that the source has settled. The nominal output impedance for this connector 
is less than 10 ohms.

16. RF OUT

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “18. RF OUTPUT” on page 8.

17. EXT 1 Input

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “11. EXT 1 INPUT” on page 7.

18. EXT 2 Input

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “12. EXT 2 INPUT” on page 7.

19. LF OUT

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “13. LF OUTPUT” on page 8.

20. PULSE SYNC OUT

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “19. SYNC OUT” on page 8.
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21. PULSE VIDEO OUT

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “20. VIDEO OUT” on page 9.

22. PULSE/TRIG GATE INPUT

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “22. GATE/ PULSE/ TRIGGER INPUT” on page 9.

23. ALC INPUT

On standard instruments, this connector resides on the front panel. For a description of this 
connector, see “15. ALC INPUT” on page 8.
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2 Basic Operation

In the following sections, this chapter describes the operation of the Agilent E8663B analog signal 
generator:

• “Using Table Editors” on page 22

• “Configuring a Continuous Wave RF Output” on page 24

• “Configuring a Swept RF Output” on page 26

• “Turning On a Modulation Format” on page 31

• “Applying a Modulation Format to the RF Output” on page 31

• “Using Data Storage Functions” on page 32

• “Using the Instrument State Registers” on page 34

• “Using Security Functions” on page 36

• “Enabling Options” on page 41

• “Using the Web Server” on page 42
Agilent E8663B Analog Signal Generator User’s Guide 21



Basic Operation
Using Table Editors
Using Table Editors
Table editors simplify configuration tasks, such as creating a list sweep. This section provides information 
to familiarize you with basic table editor functionality using the List Mode Values table editor as an 
example.

Press Preset > Sweep/List > Configure List Sweep.

The signal generator displays the List Mode Values table editor, as shown below.

Figure 2-1

Active Function Area  displays the active table item while its value is edited

Cursor  an inverse video identifier used to highlight specific table items for 
selection and editing

Table Softkeys  select table items, preset table values, and modify table structures

Table Items  values arranged in numbered rows and titled columns (The 
columns are also known as data fields. For example, the column 
below the Frequency title is known as the Frequency data field).

Cursor

Table Softkeys Table Name Table Items

Active Function Area
22 Agilent E8663B Analog Signal Generator User’s Guide



Basic Operation
Configuring the RF Output
Table Editor Softkeys

The following table editor softkeys are used to load, navigate, modify, and store table item values.

Edit Item  displays the selected item in the active function area of the display where the item’s 
value can be modified

Insert Row  inserts an identical row of table items above the currently selected row

Delete Row  deletes the currently selected row

Goto Row  opens a menu of softkeys (Enter, Goto Top Row, Goto Middle Row, Goto Bottom Row, Page Up, and 
Page Down) used to quickly navigate through the table items

Insert Item  inserts an identical item in a new row below the currently selected item

Delete Item  deletes the item from the bottom row of the currently selected column

Page Up and
Page Down  displays table items that occupy rows outside the limits of the ten- row table display 

area

More (1 of 2)  accesses Load/Store and its associated softkeys

Load/Store  opens a menu of softkeys (Load From Selected File, Store To File, Delete File, Goto Row, Page Up, and 
Page Down) used to load table items from a file in the memory catalog, or to store the 
current table items as a file in the memory catalog

Modifying Table Items in the Data Fields
1. If not already displayed, open the List Mode Values table editor (Figure 2- 1 on page 22): 

Press Preset > Sweep/List > Configure List Sweep

2. Use the arrow keys or the knob to move the table cursor over the desired item.

In Figure 2- 1, the first item in the Frequency data field is selected.

3. Press Edit Item.

The selected item is displayed in the active function area of the display.

4. Use the knob, arrow keys, or the numeric keypad to modify the value.

5. Press Enter.

The modified item is now displayed in the table.

Configuring the RF Output
This section provides information on how to create continuous wave and swept RF (page 26) outputs. 
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Configuring a Continuous Wave RF Output

These procedures demonstrate how to set the following parameters:

• RF output frequency
• frequency reference and frequency offset (page 25)
• RF output amplitude (page 25)
• amplitude reference and amplitude offset (page 26)

Setting the RF Output Frequency

Set the RF output frequency to 700 MHz, and increment or decrement the output frequency in 1 MHz steps.

1. Return the signal generator to the factory- defined state: Press Preset.

NOTE You can change the preset condition of the signal generator to a user- defined state. For these 
examples, however, use the factory- defined preset state (set the Preset Normal User softkey in the 
Utility menu to Normal).

2. Observe the FREQUENCY area of the display (in the upper left corner).

The value displayed is the maximum specified frequency of the signal generator.

3. Press RF On/Off.

The RF On/Off hardkey must be pressed before the RF signal is available at the 
RF OUTPUT connector. The display annunciator changes from RF OFF to RF ON. The maximum 
specified frequency should be output at the RF OUTPUT connector (at the signal generator’s minimum 
power level).

4. Press Frequency > 700 > MHz.

The 700 MHz RF frequency should be displayed in the FREQUENCY area of the display and also in the 
active entry area.

5. Press Frequency > Incr Set > 1 > MHz.

This changes the frequency increment value to 1 MHz.

6. Press the up arrow key.

Each press of the up arrow key increases the frequency by the increment value last set with the Incr Set 
hardkey. The increment value is displayed in the active entry area.

7. The down arrow decreases the frequency by the increment value set in the previous step. Practice 
stepping the frequency up and down in 1 MHz increments.

You can also adjust the RF output frequency using the knob. As long as frequency is the active function 
(the frequency is displayed in the active entry area), the knob will increase and decrease the RF output 
frequency.

8. Use the knob to adjust the frequency back to 700 MHz.
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Setting the Frequency Reference and Frequency Offset

The following procedure sets the RF output frequency as a reference frequency to which all other 
frequency settings are relative. When the frequency reference is set, the display will read 0.00 Hz (the 
frequency output of the signal generator’s hardware minus the reference frequency). Although the display 
changes, the actual frequency output is 700 MHz (from step 8 above). Any subsequent frequency changes 
are shown as increments or decrements to the 0 Hz reference.

The Frequency Reference Set function is not an active function. Once it is set, any change to the frequency 
setting appears as a frequency reading on the signal generator’s front- panel display. For example,

1. Preset the signal generator: Press Preset.

2. Set the frequency reference to 700 MHz: 
Press: Frequency > 700 > MHz > More (1 of 3) > Freq Ref Set.

This activates the frequency reference mode, sets the output frequency (700 MHz) as the reference 
value, and toggles the Freq Ref softkey On. The FREQUENCY area displays 0.000 Hz. This reading is the 
frequency output of the signal generator’s hardware (700 MHz) minus the reference value (700 MHz). 
The signal generator’s true output frequency is 700 MHz. If the Freq Ref softkey is toggled to Off, the 
front- panel will indicate the actual frequency: 700 MHz. The REF indicator appears on the front- panel 
display and the Freq Ref Off On softkey toggles to On.

3. Turn on the RF output: Press RF On/Off.

The display annunciator changes from RF OFF to RF ON. The RF frequency at the RF OUTPUT 
connector is 700 MHz.

4. Set the frequency increment value to 1 MHz: Press Frequency > Incr Set > 1 > MHz.

5. Increment the output frequency by 1 MHz: Press the up arrow key.

The FREQUENCY area display changes to show 1.000 000 000 MHz, which is the frequency output by the 
hardware (700 MHz + 1 MHz) minus the reference frequency (700 MHz). The frequency at the RF 
OUTPUT changes to 701 MHz.

6. Enter a 1 MHz offset: Press More (1 of 3) > Freq Offset > 1 > MHz.

The FREQUENCY area displays 2.000 000 00 MHz, which is the frequency output by the hardware 
(701 MHz) minus the reference frequency (700 MHz) plus the offset (1 MHz). The OFFS indicator 
activates. The frequency at the RF OUTPUT connector is still 701 MHz.

Setting the RF Output Amplitude
1. Preset the signal generator: Press Preset.

The AMPLITUDE area of the display shows the minimum power level of the signal generator. This is the 
normal preset RF output amplitude.

2. Turn on the RF output: Press RF On/Off.
The display annunciator changes to RF ON. At the RF OUTPUT connector, the RF signal is output at the 
minimum power level.
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3. Change the amplitude to −20 dBm: Press Amplitude > −20 > dBm.

The new output power displays in the AMPLITUDE area of the display and in the active entry area. Until 
you press a different front panel function key, amplitude remains the active function. You can also 
change the amplitude using the up and down arrow keys or the knob.

Setting the Amplitude Reference and Amplitude Offset

The following procedure sets the RF output power as an amplitude reference to which all other amplitude 
parameters are relative. The amplitude initially shown on the display is 0 dB (the power output by the 
hardware minus the reference power). Although the display changes, the output power does not change. 
Any subsequent power changes are shown as incremental or decremental to 0 dB. 

1. Press Preset.

2. Set the amplitude to −20 dBm: Press Amplitude > -20 > dBm.

3. Activate the amplitude reference mode and set the current output power (−20 dBm) as the reference 
value: Press More (1 of 2) > Ampl Ref Set.

The AMPLITUDE area displays 0.00 dB, which is the power output by the hardware (−20 dBm) minus 
the reference value (−20 dBm). The REF indicator activates and the Ampl Ref Off On softkey toggles On.

4. Turn the RF output on: Press RF On/Off.
The display annunciator changes to RF ON. The power at the RF OUTPUT connector is −20 dBm. 

5. Change the amplitude increment value to 10 dB: Press Incr Set > 10 > dB.

6. Use the up arrow key to increase the output power by 10 dB.

The AMPLITUDE area displays 10.00 dB, which is the power output by the hardware 
(- 20 dBm plus 10 dBm) minus the reference power (−20 dBm). The power at the RF OUTPUT connector 
changes to −10 dBm.

7. Enter a 10 dB offset: Press Ampl Offset > 10 > dB.

The AMPLITUDE area displays 20.00 dB, which is the power output by the hardware (−10 dBm) minus 
the reference power (−20 dBm) plus the offset (10 dB). The OFFS indicator activates. The power at the 
RF OUTPUT connector is still −10 dBm.

Configuring a Swept RF Output

An E8663B signal generator has two sweep types: step sweep and list sweep.

The signal generator indicates the sweep advance in a progress bar on the front- panel display. If the sweep 
time is greater than one second, the progress bar sweep advances according to the frequency span of each 
segment. For each segment in the span, the progress bar displays the full segment and then the sweep is 
taken. With sweep times less than one second, the progress bar is drawn, the sweep taken, and the 
progress bar is then blanked. 
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NOTE List sweep data cannot be saved within an instrument state, but can be saved to the memory 
catalog. For instructions on saving list sweep data, see “Storing Files to the Memory Catalog” 
on page 33. 

During swept RF output, the FREQUENCY and AMPLITUDE areas of the signal generator’s display 
are deactivated, depending on what is being swept.

Step sweep (see page 27) provides a linear progression through the start- to- stop frequency and/or 
amplitude values, while list sweep enables you to create a list of arbitrary frequency, amplitude, and 
dwell time values and sweep the RF output based on that list.

The list sweep example uses the points created in the step sweep example as the basis for a new list sweep. 

The signal generator provides a softkey, Sweep Retrace Off On, that lets you configure single sweep 
behavior. When sweep retrace is on, the signal generator will retrace the sweep to the first point of the 
sweep. If the sweep retrace is off, the sweep will stop and remain on the last point in the sweep. 

Using Step Sweep

Step sweep provides a linear progression through the start- to- stop frequency and/or amplitude values. You 
can toggle the direction of the sweep, up or down. When the Sweep Direction Down Up softkey is set to Up, 
values are swept from the start amplitude/frequency to the stop amplitude/frequency. When set to Down, 
values are swept from the stop amplitude/frequency to the start amplitude/frequency.

When a step sweep is activated, the signal generator sweeps the RF output based on the values entered for 
RF output start and stop frequencies and amplitudes, a number of equally spaced points (steps) to dwell 
upon, and the amount of dwell time at each point; dwell time is the minimum period of time after the 
settling time that the signal generator will remain at its current state. The frequency, amplitude, or 
frequency and amplitude of the RF output will sweep from the start amplitude/frequency to the stop 
amplitude/frequency, dwelling at equally spaced intervals defined by the # Points softkey value.

To Configure a Single Step Sweep

In this procedure, you create a step sweep with nine, equally- spaced points, and the following parameters:

• frequency range from 500 MHz to 600 MHz
• amplitude from −20 dBm to 0 dBm
• dwell time 500 ms at each point

1. Press Preset.

2. Press Sweep/List.
This opens a menu of sweep softkeys.

3. Press Sweep Repeat Single Cont.
This toggles the sweep repeat from continuous to single.

4. Press Configure Step Sweep.

5. Press Freq Start > 500 > MHz.
This changes the start frequency of the step sweep to 500 MHz.

6. Press Freq Stop > 600 > MHz.
This changes the stop frequency of the step sweep to 600 MHz.

7. Press Ampl Start > -20 > dBm.
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This changes the amplitude level for the start of the step sweep.

8. Press Ampl Stop > 0 > dBm.
This changes the amplitude level for the end of the step sweep.

9. Press # Points > 9 > Enter.
This sets the number of sweep points to nine.

10. Press Step Dwell > 500 > msec.
This sets the dwell time at each point to 500 milliseconds.

11. Press Return > Sweep > Freq & Ampl.

This sets the step sweep to sweep both frequency and amplitude data. Selecting this softkey returns 
you to the previous menu and turns on the sweep function.

12. Press RF On/Off.
The display annunciator changes from RF OFF to RF ON.

13. Press Single Sweep.

A single sweep of the frequencies and amplitudes configured in the step sweep is executed and 
available at the RF OUTPUT connector. On the display, the SWEEP annunciator appears for the duration 
of the sweep and a progress bar shows the progression of the sweep. The Single Sweep softkey can also be 
used to abort a sweep in progress. To see the frequencies sweep again, press Single Sweep to trigger the 
sweep.

To Configure a Continuous Step Sweep

Press Sweep Repeat Single Cont.

This toggles the sweep from single to continuous. A continuous repetition of the frequencies and 
amplitudes configured in the step sweep are now available at the RF OUTPUT connector. The SWEEP 
annunciator appears on the display, indicating that the signal generator is sweeping and progression of the 
sweep is shown by a progress bar. 

Using List Sweep

List sweep enables you to create a list of arbitrary frequency, amplitude, and dwell time values and sweep 
the RF output based on the entries in the List Mode Values table. 

Unlike a step sweep that contains linear ascending/descending frequency and amplitude values, spaced at 
equal intervals throughout the sweep, list sweep frequencies and amplitudes can be entered at unequal 
intervals, nonlinear ascending/descending, or random order. 

For convenience, the List Mode Values table can be copied from a previously configured step sweep. Each 
step sweep point’s associated frequency, amplitude and dwell time values are entered into a row in the List 
Mode Values table, as the following example illustrates.
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To Configure a Single List Sweep Using Step Sweep Data

In this procedure, you will leverage the step sweep points and change the sweep information by editing 
several points in the List Mode Values table. For information on using tables, see “Using Table 
Editors” on page 22.

1. Press Sweep Repeat Single Cont.

This toggles the sweep repeat from continuous to single. The SWEEP annunciator is turned off. The 
sweep will not occur until it is triggered.

2. Press Sweep Type List Step.

This toggles the sweep type from step to list.

3. Press Configure List Sweep.

This opens another menu displaying softkeys that you will use to create the sweep points. The display 
shows the current list data. (When no list has been previously created, the default list contains one 
point set to the signal generator’s maximum frequency, minimum amplitude, and a dwell time of 2 ms.)

4. Press More (1 of 2) > Load List From Step Sweep > Confirm Load From Step Data. 

The points you defined in the step sweep are automatically loaded into the list.

To Edit List Sweep Points
1. Press Return > Sweep > Off.

Turning the sweep off allows you to edit the list sweep points without generating errors. If sweep 
remains on during editing, errors occur whenever one or two point parameters (frequency, power, and 
dwell) are undefined.

2. Press Configure List Sweep.

This returns you to the sweep list table.

3. Use the arrow keys to highlight the dwell time in row 1.

4. Press Edit Item.

The dwell time for point 1 becomes the active function.

5. Press 100 > msec.

This enters 100 ms as the new dwell time value for row 1. Note that the next item in the table (in this 
case, the frequency value for point 2) becomes highlighted after you press the terminator softkey.

6. Using the arrow keys, highlight the frequency value in row 4.
Agilent E8663B Analog Signal Generator User’s Guide 29



Basic Operation
Configuring the RF Output
7. Press Edit Item > 545 > MHz.

This changes the frequency value in row 4 to 545 MHz.

8. Highlight any column in the point 7 row and press Insert Row. 

This adds a new point between points 7 and 8. A copy of the point 7 row is placed between 
points 7 and 8, creating a new point 8, and renumbering the successive points.

9. Highlight the frequency item for point 8, then press Insert Item.

Pressing Insert Item shifts frequency values down one row, beginning at point 8. Note that the original 
frequency values for both points 8 and 9 shift down one row, creating an entry for point 10 that 
contains only a frequency value (the power and dwell time items do not shift down).

The frequency for point 8 is still active.

10. Press 590 > MHz.

11. Press Insert Item > -2.5 > dBm. 

This inserts a new power value at point 8 and shifts down the original power values for points 8 and 9 
by one row.

12. Highlight the dwell time for point 9, then press Insert Item.

A duplicate of the highlighted dwell time is inserted for point 9, shifting the existing value down to 
complete the entry for point 10.

To Configure a Single List Sweep
1. Press Return > Sweep > Freq & Ampl

This turns the sweep on again. No errors should occur if all parameters for every point have been 
defined in the previous editing process.

2. Press Single Sweep.

The signal generator will single sweep the points in your list. The SWEEP annunciator activates during 
the sweep.

3. Press More (1 of 2) > Sweep Trigger > Trigger Key.

This sets the sweep trigger to occur when you press the Trigger hardkey.

4. Press More (2 of 2) > Single Sweep.

This arms the sweep. The ARMED annunciator is activated.

5. Press the Trigger hardkey.

The signal generator will single sweep the points in your list and the SWEEP annunciator will be 
activated during the sweep.

To Configure a Continuous List Sweep

Press Sweep Repeat Single Cont.

This toggles the sweep from single to continuous. A continuous repetition of the frequencies and 
amplitudes configured in the list sweep are now available at the RF OUTPUT connector. The SWEEP 
annunciator appears on the display, indicating that the signal generator is sweeping and progression of the 
sweep is shown by a progress bar. 
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Modulating a Signal
This section describes how to turn on a modulation format, and how to apply it to the RF output.

Turning On a Modulation Format

A modulation format can be turned on prior to or after setting the signal parameters.

1. Access the first menu within the modulation format. 
This menu displays a softkey that associates the format’s name with off and on. For example, AM > 
AM Off On. For some formats, the off/on key may appear in additional menus other than the first 
one.

2. Press the modulation format off/on key until On highlights.
Figure 2- 2 shows the portion of the AM modulation format’s first menu that displays the state of 
the modulation format, as well as the active modulation format annunciator.

The modulation format generates, but the carrier signal is not modulated until you apply it to the RF 
output (see page 31).

Depending on the modulation format, the signal generator may require a few seconds to build the signal. 

Figure 2-2 Example of AM Modulation Format Off and On

Applying a Modulation Format to the RF Output

The carrier signal is modulated when the Mod On/Off key is set to On, and an individual modulation format 
is active. 

When the Mod On/Off key is set to Off, the MOD OFF annunciator appears on the display. When the key is set 
to On, the MOD ON annunciator shows in the display, whether or not there is an active modulation format. 
The annunciators simply indicate whether the carrier signal will be modulated when a modulation format 
is turned on.

 

 Modulation format is on

Active Modulation Format Annunciator
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To Turn RF Output Modulation On

Press the Mod On/Off key until the MOD ON annunciator appears in the display.

The carrier signal should be modulated with all active modulation formats. This is the factory default.

To Turn RF Output Modulation Off

Press the Mod On/Off key until the MOD OFF annunciator appears in the display.

The carrier signal is no longer modulated or capable of being modulated when a modulation format is 
active.

Figure 2-3 Carrier Signal Modulation Status

Using Data Storage Functions
This section explains how to use the two forms of signal generator data storage: the memory catalog and 
the instrument state register.

Using the Memory Catalog

The Memory Catalog is the signal generator’s interface for viewing, storing, and saving files; it can be 
accessed through the signal generator’s front panel or a remote controller. (For information on performing 
these tasks remotely, see the E8663B Analog Signal Generator Programming Guide.)

Mod Set to On—Carrier is Modulated

AM Modulation Format is Active

AM Modulation Format is Active

Mod Set to Off—Carrier is 
not Modulated

Mod Set to On—Carrier is 
not Modulated

No Active Modulation Format
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Storing Files to the Memory Catalog

To store a file to the memory catalog, first create a file. For this example, use the default list sweep table.

1. Press Preset.

2. Press Sweep/List > Configure List Sweep > More (1 of 2) > Load/Store.

This opens the “Catalog of List Files”.

3. Press Store to File.

This displays a menu of alphabetical softkeys for naming the file. Store to: is displayed in the active 
function area.

4. Enter the file name LIST1 using the alphabetical softkeys and the numeric keypad (for the numbers 0 
to 9).

5. Press Enter.

The file should be displayed in the “Catalog of List Files”, showing the file name, file type, file size, and 
the date and time the file was modified.

Viewing Stored Files in the Memory Catalog
1. Press Utility > Memory Catalog > Catalog Type.

All files in the memory catalog are listed in alphabetical order, regardless of which catalog type you 
select. File information appears on the display and includes the file name, file type, file size, and the 
date and time the file was modified.

2. Press List.

The “Catalog of List Files” is displayed.

3. Press Catalog Type > State.

The “Catalog of State Files” is displayed.

Table 2-1 Memory Catalog File Types and Associated Data

Binary binary data

State instrument state data (controlling instrument operating parameters, 
such as frequency, amplitude, and mode)

LIST sweep data from the List Mode Values table including frequency, 
amplitude, and dwell time

User Flatness user flatness calibration correction pair data (user- defined frequency 
and corresponding amplitude correction values)

FIR Finite Impulse Response (FIR) filter coefficients

Shape burst shape of a pulse

Bit Bit
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4. Press Catalog Type > All.

The “Catalog of All Files” is displayed. For a complete list of file types, refer to Table 2- 1 on 
page 33.

Using the Instrument State Registers

The instrument state register is a section of memory divided into 10 sequences (numbered 0 through 9) 
with each sequence consisting of 100 registers (numbered 00 through 99). Instrument state sequences and 
registers are used to store and recall instrument settings and provide a quick way to reconfigure the signal 
generator when switching between different instrument and signal configurations. The signal generator 
has 20 MB available for data and instrument state storage. The signal generator Instrument state files can 
vary in length depending on the signal generator’s configuration.

File data, such as modulation formats and table entries, are not stored with the save function. Only setups 
such as frequency, attenuation, power and other user- defined settings that do not survive a power cycle or 
instrument reset can be saved to a sequence and register. Any data file associated with the instrument 
state will only be referenced by its file name. Once an instrument state has been saved, recalling that state 
will set up the generator with the saved settings and load the associated file data. 

For more information on storing file data such as modulation formats and table entries refer to 
“Storing Files to the Memory Catalog” on page 33. Refer to the E8663B Analog Signal Generator 
Programming Guide and the E8663B Analog Signal Generator Key Reference for more information 
on the save and recall function. 

NOTE A reference to a file is saved along with the instrument state. However, no data is saved with the 
save function. You must store file data, using store commands, in a different memory location. 

Saving an Instrument State
1. Preset the signal generator, then turn on amplitude modulation (the AM annunciator will turn on):

a. Press Frequency > 800 > MHz.
b. Press Amplitude > 0 > dBm.
c. Press AM > AM Off On.

2. Press Save > Select Seq.

The sequence number becomes the active function. The signal generator displays the last sequence 
used. Using the arrow keys, set the sequence to 1.

3. Press Select Reg.

The register number in sequence 1 becomes the active function. The signal generator displays either 
the last register used accompanied by the text: (in use), or (if no registers are in use) register 00 
accompanied by the text: (available). Use the arrow keys to select register 01.

4. Press Save Seq[1] Reg[01].

This saves this instrument state in sequence 1, register 01 of the instrument state register.
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5. Press Add Comment to Seq[1] Reg[01].

This enables you to add a descriptive comment to sequence 1 register 01. 

6. Using the alphanumeric softkeys or the knob, enter a comment and press Enter.

7. Press Edit Comment In Seq[1] Reg[01].

If you wish, you can now change the descriptive comment for sequence 1 register 01. 

After making changes to an instrument state, you can save it back to a specific register by highlighting that 
register and pressing Re-SAVE Seq[n] Reg[nn].

Recalling an Instrument State

Using this procedure, you will learn how to recall instrument settings saved to an instrument state register.

1. Press Preset.

2. Press the Recall hardkey.

Notice that the Select Seq softkey shows sequence 1. (This is the last sequence that you used.)

3. Press RECALL Reg.

The register to be recalled in sequence 1 becomes the active function. Press the up arrow key once to 
select register 1. Your stored instrument state settings should have been recalled.

Deleting Registers and Sequences

These procedures describe how to delete registers and sequences saved to an instrument state register.

Deleting a Specific Register within a Sequence
1. Press Preset.

2. Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

3. Press Select Seq and enter the sequence number containing the register you want to delete.

4. Press Select Reg and enter the register number you want to delete.

Notice that the Delete Seq[n] Reg[nn] should be loaded with the sequence and register you want to delete.

5. Press Delete Seq[n] Reg[nn].

This deletes the chosen register.

Deleting All Registers within a Sequence
1. Press Preset.

2. Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

3. Press Select Seq and enter the sequence number containing the registers you want to delete.

4. Press Delete all Regs in Seq[n].

This deletes all registers in the selected sequence.
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Deleting All Sequences

CAUTION Be sure you want to delete the contents of all registers and all sequences in the instrument 
state register.

1. Press Preset.

2. Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

3. Press Delete All Sequences.

This deletes all of the sequences saved in the instrument state register.

Using Security Functions
This section describes how to use the signal generator’s security functions to protect and remove classified 
proprietary information stored or displayed in the instrument. All security functions described in this 
section also have an equivalent SCPI command for remote operation. (Refer to the “System Commands” 
chapter of the E8663B Analog Signal Generator SCPI Command Reference for more information.)

Understanding E8663B Memory Types

The E8663B signal generator comprises several memory types, each used for storing a specific type of data. 
Before removing sensitive data, it is important to understand how each memory type is used in the signal 
generator. The following tables describe each memory type used in the base instrument.

Table 2-2 Base Instrument Memory 

Memory Type 
and Size
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Purpose/Contents Data Input Method Location in Instrument and Remarks

Main Memory 
(SDRAM)

64 MB

Yes No firmware operating memory operating system 
(not user)

CPU board, not battery backed.

Main Memory 
(Flash)

20 MB

Yes Yes factory calibration/configuration data

user file system, which includes 
instrument status backup, flatness 
calibration, IQ calibration, instrument 
states, waveforms (including header and 
marker data), modulation definitions, 
and sweep lists

firmware upgrades 
and user- saved data

CPU board (same chip as firmware memory, but 
managed separately)

Because this 32- MB memory chip contains 20 MB of 
user data (described here) and 12 MB of firmware 
memory, a selective chip erase is performed. User data 
areas are selectively and completely sanitized when you 
perform the Erase and Sanitize function.
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Firmware 
Memory (Flash)

12 MB

No Yes main firmware image factory installed or 
firmware upgrade

CPU board (same chip as main flash memory, but 
managed separately)

During normal operation, this memory cannot be 
overwritten except for LAN configuration. It is only 
overwritten during the firmware installation or upgrade 
process.

Because this 32- MB memory chip contains 20 MB of 
user data and 12 MB of firmware memory (described 
here), a selective chip erase is performed. User data 
areas are selectively and completely sanitized when you 
perform the Erase and Sanitize function.

Yes Yes LAN configuration front panel entry

Battery Backed 
Memory 
(SRAM)

512 kB

Yes Yes user- editable data (table editors)

last instrument state, last instrument 
state backup, and persistent instrument 
state and instrument status

firmware 
operations

CPU board

The battery can be removed to sanitize the memory, but 
must be reinstalled for the instrument to operate. The 
battery is located on the CPU board.

Bootrom 
Memory (Flash)

128 kB

No Yes CPU bootup program and firmware 
loader/updater

factory 
programmed

CPU board

During normal operation, this memory cannot be 
overwritten or erased. This read- only data is 
programmed at the factory.

Calibration 
Backup Memory 
(Flash)

512 KB

No Yes factory calibration/configuration data 
backup

no user data

factory or service 
only

motherboard

Boards Memory 
(Flash)

512 Bytes

No Yes factory calibration and information files, 
code images, and self- test limits

no user data

factory or service 
only

all RF boards, baseband generator, and motherboard

Micro-  
processor 
Cache (SRAM)

3 kB

Yes No CPU data and instruction cache memory is managed 
by CPU, not user

CPU board, not battery backed.

Table 2-2 Base Instrument Memory  (Continued)

Memory Type 
and Size
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Purpose/Contents Data Input Method Location in Instrument and Remarks
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Removing Sensitive Data from E8663B Memory

When moving the E8663B signal generator from a secure development environment, you can remove any 
classified proprietary information stored in the instrument. This section describes several security 
functions you can use to remove sensitive data from your instrument.

Erase All
This function removes all user files, user flatness calibrations, user I/Q calibrations, and resets all table 
editors with original factory values, ensuring that user data and configurations are not accessible or 
viewable. The instrument appears as if it is in its original factory state, however, the memory is not 
sanitized. This action is relatively quick, taking less than one minute (the exact time depends on the 
number of files).

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase All > Confirm Erase.

NOTE This function is different than pressing Utility > Memory Catalog > More (1 of 2) > Delete All Files, which 
deletes all user files, but does not reset the table editors.

Erase and Overwrite All

This function performs the same actions as Erase All and then clears and overwrites the various 
memory types in accordance with Department of Defense (DoD) standards, as described below.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Overwrite All > 
Confirm Overwrite.

Erase and Sanitize All

This function performs the same actions as Erase and Overwrite All and then adds more overwriting 
actions. After executing this function, you must manually perform some additional steps for the 
sanitization to comply with Department of Defense (DoD) standards. These actions and steps are described 
below.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Sanitize All > 
Confirm Sanitize.

Removing Persistent State Information Not Removed During Erase

Persistent State

The persistent state settings contain instrument setup information that can be toggled within predefined 
limits such as display intensity, contrast and the GPIB address. In vector models, the user IQ Cal is also 

SRAM All addressable locations are overwritten with random characters.

CPU Flash All addressable locations are overwritten with random characters and then the flash blocks are erased. This 
accomplishes the same purpose of a chip erase, however, only the areas that are no longer in use are erased and the 
factory calibration files are left intact. System files are restored after erase.

SRAM All addressable locations are overwritten with random characters.
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saved in this area.

The following key presses or SCPI commands can be used to clear the IQ cal file and to set the operating 
states that are not affected by a signal generator power- on, preset, or *RST command to their factory 
default:

Instrument Setup

• On the front panel, press: Utility > Power On/Preset > Restore System Defaults > Confirm Restore Sys Defaults
• Or send the command: :SYSTem:PRESet:PERSistent

LAN Setup

The LAN setup (hostname, IP address, subnet mask, and default gateway) information is not defaulted with a signal 
generator power- on or *RST command. This information can only be changed or cleared by entering new data.

User IQ Cal File (Vector Models Only)

When a user- defined IQ calibration has been performed, the cal file data is removed by setting the cal file to default, as 
follows:

1. On the front panel, press: I/Q > I/Q Calibration > Revert to Default Cal Settings

2. Send these commands:

• :CAL:IQ:DEF

• :CAL:WBIQ:DEF

Using the Secure Mode

The secure mode automatically applies the selected Security Level action the next time the instrument’s 
power is cycled.

Setting the Secure Mode Level
1. Press Utility > Memory Catalog > More (1 of 2) > Security > Security Level.

2. Choose from the following selections:

None − equivalent to a factory preset, no user information is lost
Erase − equivalent to Erase All
Overwrite − equivalent to Erase and Overwrite All
Sanitize − equivalent to Erase and Sanitize All
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Activating the Secure Mode

CAUTION Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease the 
security level; the erasure actions for that security level execute at the next power cycle. Once 
you activate secure mode, you can only increase the security level until you cycle power. For 
example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but the secure mode is 
not activated.

Press Utility > Memory Catalog > More (1 of 2) > Security > Enter Secure Mode > Confirm.

The Enter Secure Mode softkey changes to Secure Mode Activated.

If Your Instrument is Not Functioning

If the instrument is not functioning and you cannot use the security functions, the storage media must be 
physically removed from the instrument. This requires removal of the processor board, which should then 
be rendered unusable and discarded. The instrument can then be sent to a repair facility for new parts, 
repair, and calibration. 

Refer to the E8663B Analog Signal Generator Service Guide for disassembly procedures.

Either

• Discard the processor board and send the instrument to a repair facility. A new processor board will be 
installed and the instrument will be repaired and calibrated. If the instrument is still under warranty, 
you will not be charged for the new processor board.

or

• If you have another working instrument, install the processor board into that instrument and erase the 
memory. Then reinstall the processor board back into the non- working instrument and send it to a 
repair facility for repair and calibration. If you discover that the processor board does not function in 
the working instrument, discard the processor board and note that it caused the instrument failure on 
the repair order. If the instrument is still under warranty, you will not be charged for the new processor 
board.

Using the Secure Display

This function prevents unauthorized personnel from reading the instrument display and tampering with 
the current configuration through the front panel. The display is blanked, except for the message *** 
SECURE DISPLAY ACTIVATED ***, and the front panel keys are disabled. Once this function is activated, 
the power must be cycled to re- enable the display and front panel keys.

To apply this function, press Utility > Display > More (1 of 2) > Activate Secure Display > Confirm Secure Display
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Figure 2-4 E8663B Screen with Secure Display Activated

Enabling Options
You can retrofit your signal generator after purchase to add new capabilities. Some new optional features 
are implemented in hardware that you must install. Some options are implemented in software, but 
require the presence of optional hardware in the instrument. This example shows you how to enable 
software options.

Enabling a Software Option

A license key (provided on the license key certificate) is required to enable each software option. 

1. Access the Software Options menu:
Utility > Instrument Adjustments > Instrument Options > Software Options. 
The following is an example of the signal generator display, which lists any enabled software options, 
and any software options that can be enabled:
Agilent E8663B Analog Signal Generator User’s Guide 41



Basic Operation
Using the Web Server
2. Verify that the host ID shown on the display matches the host ID on the license key certificate. The host 
ID is a unique number for every instrument. If the host ID on the license key certificate does not match 
your instrument, the license key cannot enable the software option.

3. Verify that any required hardware is installed. Because some software options are linked to specific 
hardware options, before the software option can be enabled, the appropriate hardware option must be 
installed. If the software option that you intend to install is listed in a grey font, the required hardware 
may not be installed (look for an X in the “Selected” column of the appropriate hardware option in the 
Hardware Options menu).

4. Enable the software option:

a. Highlight the desired option.

b. Press Modify License Key, and enter the 12- character license key (from the license key certificate).

c. Verify that you want to reconfigure the signal generator with the new option:
Proceed With Reconfiguration > Confirm Change

The instrument enables the option and reboots.

Using the Web Server
You can communicate with the signal generator using the Web Server. This service uses TCP/IP 
(Transmission Control Protocol/Internet Protocol) to communicate with the signal generator over the 
internet. 

The Web Server uses a client/server model where the client is the web browser on your PC or workstation 
and the server is the signal generator. When you enable the Web Server, you can access a web page that 
resides on the signal generator. 

Software options are displayed here
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The Web- Enabled E8663B web page, shown in Figure 2- 5, provides general information on your signal 
generator and a means to control the instrument either by using a remote front- panel interface or 
using SCPI (Standard Communication for Programmable Instruments) commands. The web page also 
has links to Agilent’s products, support, manuals, and website. 

NOTE The Web Server service is compatible with the latest version of the Microsoft© Internet Explorer 
web browser.1

The Signal Generator Web Control menu button on the Web- Enabled signal generator web page will access 
a second web page. This web page, shown in Figure 2- 6, provides a virtual instrument interface that 
can be used to control the signal generator. You can use the mouse to click on the signal generator’s 
front panel hardkeys, softkeys and number pad. There is also a text box that can be used to send 
SCPI commands to the instrument. 

Activating the Web Server 

Perform the following steps to access the Web Server. 

1. Turn on the Web Server by pressing Utility > GPIB/RS–232 LAN > LAN Services Setup > Web Server On.

2. Press the Proceed With Reconfiguration softkey.

3. Press the Confirm Change (Instrument will Reboot) softkey. The signal generator will reboot. 

4. Launch your PC or workstation web browser. 

5. Enter the IP address of the signal generator in the web browser address field. For example, 
http://101.101.101.101. Replace 101.101.101.101 with your signal generator’s IP address. Press the 
Enter key on the computer’s keyboard.

NOTE The IP (Internet Protocol) address can change depending on your LAN configuration. 
Use the LAN Config Manual DHCP softkey to select a Manual or DHCP (dynamic host 
communication protocol) LAN configuration. Refer to E8663B Analog Signal Generator Key 
Reference for more information.

6. Press the enter key on the computer’s keyboard. The web browser will display the signal generator’s 
homepage as shown below in Figure 2- 5. This web page displays information about the signal 
generator and provides access to Agilent’s website.

1. Microsoft is a registered trademark of Microsoft Corp.
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Figure 2-5 Signal Generator Web Page
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7. Click the Signal Generator Web Control menu button on the left of the page. A new web page will be 
displayed as shown below in Figure 2- 6. 

Figure 2-6 Web Page Front Panel 

This web page remotely accesses all signal generator functions and operations. Use the mouse pointer to 
click on the signal generator’s hardkeys and softkeys. The results of each mouse click selection will be 
displayed on the web page. For example, click on the Frequency hardkey then use the front- panel key pad 
to enter a frequency. You can also use the up and down arrow keys to increase or decrease the frequency. 

You can use the SCPI Command text box at the bottom of the front- panel display to send commands to the 
signal generator. Enter a valid SCPI command, then click the SEND button. The results of the command 
will be displayed on a separate web page titled, “SCPI Command Processed”. You can continue using this 
web page to enter SCPI commands or you can return to the front panel web page. 

NOTE It may be necessary to use the web browser Refresh function if the web page does not update with 
new settings.
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3 Optimizing Performance

In the following sections, this chapter describes procedures that improve the performance of the 
Agilent signal generator.

• “Using the ALC” on page 47

• “Using External Leveling” on page 48

• “Creating and Applying User Flatness Correction” on page 51

• “Adjusting Reference Oscillator Bandwidth” on page 56

Using the ALC 

Selecting ALC Bandwidth

For internal leveling, the signal generator uses automatic leveling control (ALC) circuitry prior to the 
RF output. ALC bandwidth has five selections: automatic, 100 Hz, 1 kHz, 10 kHz, and 100 kHz. In 
automatic mode (the preset selection), the signal generator automatically selects the ALC bandwidth 
depending on the configuration and settings (see Figure 3- 1).

Figure 3-1 Decision Tree for Automatic ALC Bandwidth Selection

To Select an ALC Bandwidth

Press Amplitude > ALC BW > 100 Hz, 1 kHz, 10 kHz, or 100 kHz. 
This overrides the signal generator’s automatic ALC bandwidth selection with your specific selection.

For waveforms with varying amplitudes, high crest factors, or both, the recommended ALC loop 
bandwidth is 100 Hz. Limiting the loop bandwidth of the ALC circuit will prevent the ALC from 
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sampling the fast rising edges of pulsed waveforms with high crest factors found in formats such as 
802.11b, CDMA, and OFDM. A limited, or narrow bandwidth will result in a longer ALC sample time 
and a more accurate representation of the signal’s level. 

Using External Leveling
The signal generator can be externally leveled by connecting an external sensor at the point where 
leveled RF output power is desired. This sensor detects changes in RF output power and returns a 
compensating voltage to the signal generator’s ALC input. The ALC circuitry raises or lowers (levels) 
the RF output power based on the voltage received from the external sensor, ensuring constant power 
at the point of detection.

To Level with Detectors and Couplers/Splitters

External Leveling the Signal Generator

The signal generator contains a step attenuator prior to the RF output connector. During external 
leveling, the signal generator automatically holds the present attenuator setting (to avoid power 
transients that may occur during attenuator switching) as the RF amplitude is changed. A balance 
must be maintained between the amount of attenuation and the optimum ALC level to achieve the 
required RF output amplitude. For optimum accuracy and minimum noise, the ALC level should be 
greater than −10 dBm.

For example, leveling the CW output of a 30 dB gain amplifier to a level of −10 dBm requires the 
output of the signal generator to be approximately −40 dBm when leveled. This is beyond the 
amplitude limits of the ALC modulator alone, resulting in an unleveled RF output. Inserting 45 dB of 
attenuation results in an ALC level of +5 dBm, well within the range of the ALC modulator.

Figure 3- 2 illustrates a typical external leveling setup. The power level feedback to the ALC circuitry 
is taken from the external negative detector, rather than the internal signal generator detector. This 
feedback voltage controls the ALC system, leveling the RF output power at the point of detection.

To use detectors and couplers/splitters for external leveling at an RF output frequency of 
10 GHz and an amplitude of 0 dBm, follow the instructions in this section.

Required Equipment
• Agilent 8474E negative detector

• Agilent 87301D directional coupler

• cables and adapters, as required

Connect the Equipment

Set up the equipment as shown in Figure 3- 2.
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Figure 3-2 External Detector Leveling with a Directional Coupler

Configure the Signal Generator
1. Press Preset.

2. Press Frequency > 10 > GHz.

3. Press Amplitude > 0 > dBm.

4. Press RF On/Off.

5. Press Leveling Mode > Ext Detector.

This deactivates the internal ALC detector and switches the ALC input path to the front panel 
ALC INPUT connector. The EXT indicator is activated in the AMPLITUDE area of the display.

NOTE  Notice that the ATTN HOLD (attenuator hold) annunciator is displayed. During external 
leveling, the signal generator automatically uncouples the attenuator from the ALC system 
for all external leveling points. While in this mode, the RF output amplitude adjustment 
is limited to −20 to +25 dBm, the adjustment range of the ALC circuitry.

6. Observe the coupling factor printed on the directional coupler at the detector port. Typically, this 
value is −10 to −20 dB.

Enter the positive dB value of this coupling factor into the signal generator.

7. Press More (1 of 2) > Ext Detector Coupling Factor > 16 (or the positive representation of the value listed at 
the detector port of the directional coupler) > dB.

Leveled output power is now available at the output of the directional coupler.

NOTE While operating in external leveling mode, the signal generator’s displayed RF output 
amplitude is affected by the coupling factor value, resulting in a calculated approximation of 
the actual RF output amplitude. To determine the actual RF output amplitude at the point of 
detection, measure the voltage at the external detector output and refer to Figure 3- 3 or 
measure the power directly with a power meter.

Determining the Leveled Output Power

Figure 3- 3 shows the input power versus output voltage characteristics for typical Agilent 
Technologies diode detectors. Using this chart, you can determine the leveled power at the diode 
detector input by measuring the external detector output voltage. You must then add the coupling 
Agilent E8663B Analog Signal Generator User’s Guide 49



Optimizing Performance
Using External Leveling
factor to determine the leveled output power. The range of power adjustment is approximately - 20 to 
+25 dBm.

Figure 3-3 Typical Diode Detector Response at 25° C
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NOTE In the example above, 55 dB is the preferred attenuation choice, resulting in an ALC level of 
+15 dBm. This provides adequate dynamic range for AM or other functions that vary the RF 
output amplitude.

To achieve the optimum ALC level at the signal generator RF output of −40 dBm for an unmodulated 
carrier, follow these steps:

1. Press Amplitude > Set Atten > 45 > dB.

2. Press Set ALC Level > 5 > dBm. 

This sets the attenuator to 45 dB and the ALC level to +5 dBm, resulting in an RF output amplitude 
of - 40 dBm, as shown in the AMPLITUDE area of the display.

To obtain flatness- corrected power, refer to “Creating and Applying User Flatness Correction” on 
page 51.

Creating and Applying User Flatness Correction
User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 
frequency points in any frequency or sweep mode. Using an Agilent E4416A/17A or E4418B/19B 
power meter (controlled by the signal generator through GPIB) to calibrate the measurement system, 
a table of power level corrections is created for frequencies where power level variations or losses 
occur. These frequencies may be defined in sequential linear steps or arbitrarily spaced. 

To allow different correction arrays for different test setups or different frequency ranges, you may 
save individual user flatness correction tables to the signal generator’s memory catalog and recall 
them on demand.

Use the steps in the next sections to create and apply user flatness correction to the signal 
generator’s RF output.

Afterward, use the steps in “Recalling and Applying a User Flatness Correction Array” on page 55 to 
recall a user flatness file from the memory catalog and apply it to the signal generator’s RF output.
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Creating a User Flatness Correction Array

In this example, you create a user flatness correction array. The flatness correction array contains 
ten frequency correction pairs (amplitude correction values for specified frequencies), from 1 to 
10 GHz in 1 GHz intervals. 

An Agilent E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and 
E4413A power sensor are used to measure the RF output amplitude at the specified correction 
frequencies and transfer the results to the signal generator. The signal generator reads the power 
level data from the power meter, calculates the correction values, and stores the correction pairs in a 
user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a GPIB 
interface, you can enter correction values manually. 

Required Equipment
• Agilent E4416A/17A/18B/19B power meter
• Agilent E4413A E Series CW power sensor
• GPIB interface cable
• adapters and cables, as required

NOTE If the setup has an external leveling configuration, the equipment setup in Figure 3- 4 
assumes that the steps necessary to correctly level the RF output have been followed. If you 
have questions about external leveling, refer to “Using External Leveling” on page 48.

Configure the Power Meter
1. Select SCPI as the remote language for the power meter.
2. Zero and calibrate the power sensor to the power meter.
3. Enter the appropriate power sensor calibration factors into the power meter as appropriate.
4. Enable the power meter’s cal factor array.

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in Figure 3- 4.

NOTE During the process of creating the user flatness correction array, the power meter is slaved 
to the signal generator via GPIB. No other controllers are allowed on the GPIB interface.
52 Agilent E8663B Analog Signal Generator User’s Guide



Optimizing Performance
Creating and Applying User Flatness Correction
Figure 3-4 User Flatness Correction Equipment Setup

Configure the Signal Generator
1. Press Preset.

2. Configure the signal generator to interface with the power meter.

a. Press Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > Power Meter > E4416A, E4417A, E4418B, or 
E4419B.

b. Press Meter Address > enter the power meter’s GPIB address > Enter.

c. For E4417A and E4419B models, press Meter Channel A B to select the power meter’s active 
channel.

d. Press Meter Timeout to adjust the length of time before the instrument generates a timeout error 
if unsuccessfully attempting to communicate with the power meter.

3. Press More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset.

This opens the User Flatness table editor and presets the cal array frequency/correction list.

4. Press Configure Step Array.

This opens a menu for entering the user flatness step array data.

5. Press Freq Start > 1 > GHz.

6. Press Freq Stop > 3 > GHz.
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7. Press # of Points > 10 > Enter.

Steps 4, 5, and 6 enter the desired flatness- corrected frequencies into the step array.

8. Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

This populates the user flatness correction array with the frequency settings defined in the step 
array.

9. Press Amplitude > More (1 of 2) > Ampl Offset.

Enter a nominal (average) value for the gain or loss of any cables or other devices connected 
between the signal generator’s RF output and the power sensor. Refer to figure Figure 3- 4 on 
page 53. Gain is entered as a positive number while loss is entered as a negative number. 

10. Press RF On/Off.

This activates the RF output and the RF ON annunciator is displayed on the signal generator.

Perform the User Flatness Correction 

NOTE If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter 
does not have a GPIB interface, you can perform the user flatness correction manually. For 
instructions, see “Performing the User Flatness Correction Manually” on page 54.

1. Press More (1 of 2) > User Flatness > Do Cal.

Pressing the Do Cal softkey causes the signal generator to perform the user flatness correction 
routine. A progress bar is shown on the front panel display as the routine runs. The routine 
generates a table of correction points with each correction point consisting of a frequency and 
amplitude correction value for that frequency. The correction value at each point is the difference 
between the power level, as measured by the power meter, and the output power of the signal 
generator. 

NOTE A power meter timeout may occur at low power levels. If a power meter timeout error 
message appears, increase the timeout value by pressing Amplitude  > More (1 of 2) > User Flatness > 
More (1 of 2) > Meter Timeout.

2. Press Done.

Pressing the Done softkey loads the amplitude correction values into the user flatness correction 
array.

If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the stored amplitude correction 
values. The user flatness correction array title displays User Flatness: (UNSTORED) indicating 
that the current user flatness correction array data has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not 
have a GPIB interface, complete the steps in this section and then continue with the user flatness 
correction tutorial.
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1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the frequency value 
(1 GHz) for row 1. The RF output changes to the frequency value of the table row containing the 
cursor and 1.000 000 000 00 is displayed in the AMPLITUDE area of the display. 

2. Observe and record the measured value from the power meter.

3. Subtract the measured value from 0 dBm.

4. Move the table cursor over the correction value in row 1.

5. Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the correction value entered.

6. Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Use the down arrow key to place the cursor over the frequency value 
for the next row. The RF output changes to the frequency value of the table row containing the 
cursor, as shown in the AMPLITUDE area of the display. 

8. Repeat steps 2 through 7 for every entry in the User Flatness table.

Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as in the signal generator’s memory 
catalog. With several user flatness correction files saved to the memory catalog, any file can be 
recalled, loaded into the correction array, and applied to the RF output to satisfy specific RF output 
flatness requirements.

1. Press Load/Store.

2. Press Store to File.

3. Enter the file name FLATCAL1 using the alphanumeric softkeys, numeric keypad, or the knob.

4. Press Enter.

The user flatness correction array file FLATCAL1 is now stored in the memory catalog as a UFLT file.

Applying a User Flatness Correction Array
Press Return > Return > Flatness Off On to On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the 
AMPLITUDE section of the signal generator’s display and the frequency correction data contained in 
the correction array is applied to the RF output amplitude.

Recalling and Applying a User Flatness Correction Array

Before performing the steps in this section, complete “Creating a User Flatness Correction Array” on 
page 52.

1. Press Preset.

2. Press Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset.

3. Press More (2 of 2) > Load/Store.
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4. Ensure that the file FLATCAL1 is highlighted.

5. Press Load From Selected File > Confirm Load From File.

This populates the user flatness correction array with the data contained in the file FLATCAL1. 
The user flatness correction array title displays User Flatness: FLATCAL1.

6. Press Return > Flatness Off On to On.

This applies the user flatness correction data contained in FLATCAL1.

Returning the Signal Generator to GPIB Listener Mode

During the user flatness correction process, the power meter is slaved to the signal generator via 
GPIB, and no other controllers are allowed on the GPIB interface. The signal generator operates in 
GPIB talker mode, as a device controller for the power meter. In this operating mode, it cannot 
receive SCPI commands via GPIB.

If the signal generator is to be interfaced to a remote controller after performing the user flatness 
correction, its GPIB controller mode must be changed from GPIB talker to GPIB listener.

If an RF carrier has been previously configured, you must save the present instrument state before 
returning the signal generator to GPIB listener mode.

1. Save your instrument state to the instrument state register.

For instructions, see “Saving an Instrument State” on page 34.

2. Press Amplitude > More (1 of 2) > User Flatness > GPIB Listener Mode.

This presets the signal generator and returns it to GPIB listener mode. The signal generator can 
now receive remote commands executed by a remote controller connected to the GPIB interface.

3. Recall your instrument state from the instrument state register.

For instructions, see “Saving an Instrument State” on page 34.

Adjusting Reference Oscillator Bandwidth
The reference oscillator bandwidth (sometimes referred to as loop bandwidth) is adjustable in fixed 
steps for either an internal or external 10 MHz frequency reference. The reference oscillator 
bandwidth can be set to 25, 55, 125, 300, or 650 Hz.

At frequency offsets below approximately 1 kHz, the stability and phase noise are determined by the 
internal or external frequency reference. At frequency offsets above 1 kHz, stability and phase noise 
are determined by the synthesizer hardware.

To optimize the overall phase noise performance of the signal generator for your particular 
application, make this adjustment depending on your confidence in the stability and phase noise of 
the external or internal reference versus the synthesizer hardware for various frequency offsets from 
the carrier. 
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 To Select the Reference Oscillator Bandwidth

 When using the internal timebase reference:
1. Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > Internal Ref Bandwidth.

2. Select the desired bandwidth.

When using an external timebase reference:
1. Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > External Ref Bandwidth.

2. Select the desired bandwidth.

To Restore Factory Default Settings:

Internal Timebase: 125 Hz
External Timebase: 25 Hz

Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > Restore Factory Defaults.
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4 Analog Modulation

In the following sections, this chapter describes the standard continuous waveform, analog 
modulation capability, and the optional narrow pulse modulation in the Agilent E8663B Analog Signal 
Generator.

• “Analog Modulation Waveforms” on page 59

• “Configuring AM” on page 60

• “Configuring FM” on page 60

• “Configuring ΦM” on page 61

• “Configuring Pulse Modulation” on page 62

• “Configuring the LF Output” on page 63

Analog Modulation Waveforms
Available standard internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Dual- Sine  dual- sine waves with individually adjustable frequencies and a percent- of-  
peak- amplitude setting for the second tone (available from function generator 
only)

Swept- Sine  swept- sine wave with adjustable start and stop frequencies, sweep rate, and sweep 
trigger settings (available from function generator only)

Triangle  triangle wave with adjustable amplitude and frequency

Ramp  ramp with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Noise  noise with adjustable amplitude generated as a peak- to- peak value (RMS value is 
approximately 80% of the displayed value)

The signal generator can modulate the RF carrier with amplitude, frequency, phase, or standard pulse 
modulation. 

With Option UNW, the signal generator can modulate the RF carrier with narrow pulse modulation 
(20 ns minimum pulse width). 
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Configuring AM
In this example, you will learn how to generate an amplitude- modulated RF carrier. 

To Set the Carrier Frequency
1. Press Preset.

2. Press Frequency > 1340 > kHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the AM Depth and Rate
1. Press the AM hardkey.

2. Press AM Depth > 90 > %.

3. Press AM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, amplitude- modulated carrier at 1340 kHz 
with the AM depth set to 90% and the AM rate set to 10 kHz. The shape of the waveform is a sine 
wave. Notice that sine is the default selection for the AM Waveform softkey, which can be viewed by 
pressing (More 1 of 2).

To Turn on Amplitude Modulation

Follow these remaining steps to output the amplitude- modulated signal.

1. Press the AM Off On softkey to On.

2. Press the front panel RF On Off key.

The AM and RF ON annunciators are now displayed. This indicates that you have enabled amplitude 
modulation and the signal is now being transmitted from the RF OUTPUT connector.

Configuring FM
In this example, you will learn how to create a frequency- modulated RF carrier.

To Set the RF Output Frequency
1. Press Preset.

2. Press Frequency > 1 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.
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To Set the FM Deviation and Rate
1. Press the FM/ΦM hardkey.

2. Press FM Dev > 75 > kHz.

3. Press FM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, frequency- modulated carrier at 1 GHz 
with a 75 kHz deviation and a 10 kHz rate. The shape of the waveform is a sine wave. (Notice that 
sine is the default for the FM Waveform softkey. Press More (1 of 2) to see the softkey.) 

To Activate FM
1. Press FM Off On to On.

2. Press RF On/Off.

The FM and RF ON annunciators are now displayed. This indicates that you have enabled frequency 
modulation and the signal is now being transmitted from the RF OUTPUT connector.

DC Offset and External FM

Applying a DC offset to an external FM signal will shift the frequency of the FM signal above or 
below the carrier frequency, depending on the polarity of the DC level. The amount frequency shift is 
directly related to the amplitude of the DC level. A DC offset of +1.0 volt or greater will shift the 
external FM frequency by an amount equal to the maximum deviation setting. For example, if the 
signal generator CW frequency is 1 GHz and the maximum deviation setting is set to 100 kHz, an 
external DC- coupled signal with a +1.0 volt DC level used as the modulating source will center the 
FM signal at 1 GHz + 100 kHz. Keeping the same setup and settings and changing the DC level to 
+0.5 volts will center the FM signal at 1 GHz + 50 kHz. 

Configuring ΦM
In this example, you will learn how to create a phase- modulated RF carrier.

To Set the RF Output Frequency
1. Press Preset.

2. Press Frequency > 3 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the ΦM Deviation and Rate
1. Press the FM/ΦM hardkey.

2. Press the FM ΦM softkey.

3. Press ΦM Dev > .25 > pi rad. 

4. Press ΦM Rate > 10 > kHz.
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The signal generator is now configured to output a 0 dBm, phase- modulated carrier at 3 GHz with a 
0.25 p radian deviation and 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sine 
is the default for the ΦM Waveform softkey. Press More (1 of 2) to see the softkey.) 

To Activate ΦM
1. Press ΦM Off On.

2. Press RF On/Off.

The ΦM and RF ON annunciators are now displayed. This indicates that you have enabled phase 
modulation and the signal is now being transmitted from the RF OUTPUT connector.

Configuring Pulse Modulation 
In this example, you will learn how to create a gated, pulse- modulated RF carrier with an external 
trigger. 

To Set the RF Output Frequency
1. Press Preset.

2. Press Frequency > 2 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the Pulse Period, Width, and Triggering
1. Press Pulse > Pulse Period > 100 > usec.

2. Press Pulse > Pulse Width > 24 > usec.

3. Press Pulse > Pulse Source > Int Gated.

4. Connect a TTL signal to the Trigger In connector on the rear panel of the signal generator. To 
configure the trigger signal polarity, Press Utility > Instrument Adjustments > Signal Polarity 
Setup > Trigger In Polarity.

The signal generator is now configured to output a 0 dBm, pulse- modulated carrier at 2 GHz with a 
100- microsecond pulse period and 24- microsecond pulse width. The pulse source is set to internal 
gated. (Notice that Internal Free Run is the default for the Pulse Source softkey.) 

To Activate Pulse Modulation

Follow these remaining steps to output the pulse- modulated signal.

1. Press Pulse Off On to On.

2. Press RF On/Off.

The Pulse and RF ON annunciators are now displayed. This indicates that you have enabled pulse 
modulation and the signal is now being transmitted from the RF OUTPUT connector. The TTL trigger 
signal state will control pulse modulation output. 
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Configuring the LF Output
The signal generator has a low frequency (LF) output (described on page 8). The LF output’s source 
can be switched between Internal 1 Monitor, Internal 2 Monitor, Function Generator 1, or Function Generator 2.

Using Internal 1 Monitor or Internal 2 Monitor as the LF output source, the LF output provides a replica of 
the signal from the internal source that is being used to modulate the RF output. The specific 
modulation parameters for this signal are configured through the AM, FM, or FM menus.

Using Function Generator 1 or Function Generator 2 as the LF output source, the function generator section of 
the internal modulation source drives the LF output directly. Frequency and waveform are configured 
from the LF output menu, not through the AM, FM, or FM menus. You can select the waveform shape 
from the following choices:

Sine  sine wave with adjustable amplitude and frequency

Dual- Sine  dual- sine waves with individually adjustable frequencies and a percent- of-  
peak- amplitude setting for the second tone (available from function generator 1 
only)

Swept- Sine  a swept- sine wave with adjustable start and stop frequencies, sweep rate, and 
sweep trigger settings (available from function generator 1 only)

Triangle  triangle wave with adjustable amplitude and frequency

Ramp  ramp with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Noise  noise with adjustable amplitude generated as a peak- to- peak value (RMS value is 
approximately 80% of the displayed value)

DC  direct current with adjustable amplitude

NOTE The LF Out Off On softkey controls the operating state of the LF output. However, when the LF 
output source selection is Internal Monitor, you have three ways of controlling the output. You 
can use the modulation source (AM, FM, or FM) on/off key, the LF output on/off key, or the 
Mod On/Off softkey.

The RF On/Off hardkey does not apply to the LF OUTPUT connector.

To Configure the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source.

NOTE Internal modulation (Internal Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source
1. Press Preset.

2. Press the FM/ΦM hardkey.

3. Press FM Dev > 75 > kHz.

4. Press FM Rate > 10 > kHz. 
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5. Press FM Off On. 

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FM annunciator is 
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output
1. Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > Vp. 

3. Press LF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is 
frequency modulated using the Internal 1 Monitor source selection (default source).

To Configure the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source
1. Press Preset.

2. Press the LF Out hardkey.

3. Press LF Out Source > Function Generator 1.

Configuring the Waveform
1. Press LF Out Waveform > Swept-Sine.

2. Press LF Out Start Freq > 100 > Hz.

3. Press LF Out Stop Freq > 1 > kHz.

4. Press Return > Return.

This returns you to the top LF Output menu. 

Configuring the Low Frequency Output
1. Press LF Out Amplitude > 3 > Vp.

This sets the LF output amplitude to 3 Vp.

2. Press LF Out Off On.

The LF output is now transmitting a signal using Function Generator 1 that is providing a
3 Vp swept- sine waveform. The waveform is sweeping from 100 Hz to 1 kHz.
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5 Troubleshooting

This chapter provides basic troubleshooting information for the Agilent E8663B analog signal 
generator. If you do not find a solution here, refer to the E8663B Analog Signal Generator Service 
Guide.

NOTE If the signal generator displays an error, always read the error message text by pressing 
Utility > Error Info.

• “RF Output Power Problems” on page 65

• “No Modulation at the RF Output” on page 69

• “Sweep Problems” on page 70

• “Data Storage Problems” on page 71

• “Cannot Turn Off Help Mode” on page 72

• “Signal Generator Locks Up” on page 72

• “Error Messages” on page 73

• “Contacting Agilent Sales and Service Offices” on page 75

• “Returning a Signal Generator to Agilent Technologies” on page 75

RF Output Power Problems
Check the RF ON/OFF annunciator on the display. If it reads RF OFF, press RF On/Off to toggle the RF 
output on.

No RF Output Power when Playing a Waveform File

Preset the signal generator, then replay the waveform file.

If a header file is not specified for a waveform, the signal generator uses a default header file with 
unspecified settings. If you play a waveform file that has unspecified signal generator settings 
(settings not saved to the file header, see page 82), the signal generator will use the header file 
settings from the previously played file. If the previous header file had a marker routed to RF 
blanking, the RF output power will be blanked. Preset the signal generator to return the RF blanking 
marker function to its default state—off). Refer to the E8663B Analog Signal Generator Key 
Reference, Marker section, for more information.

NOTE If the default marker file is used, ensure that the Pulse/RF Blank softkey is set to None. Markers 
may have been set to Pulse/RF Blank by a previous file header. 
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RF Output Power too Low
1. Look for an OFFS or REF indicator in the AMPLITUDE area of the display.

OFFS tells you that an amplitude offset has been set. An amplitude offset changes the value shown 
in the AMPLITUDE area of the display but does not affect the output power. The amplitude 
displayed is equal to the current power output by the signal generator hardware plus the value 
for the offset.

To eliminate the offset, press the following keys:

Amplitude > More (1 of 2) > Ampl Offset > 0 > dB.

REF tells you that the amplitude reference mode is activated. When this mode is on, the displayed 
amplitude value is not the output power level. It is the current power output by the signal 
generator hardware minus the reference value set by the Ampl Ref Set softkey.

To exit the reference mode, follow these steps:

a. Press Amplitude > More (1 of 2).

b. Press Ampl Ref Off On until Off is highlighted.

You can then reset the output power to the desired level.

2. If you are using the signal generator with an external mixer, see “Signal Loss While Working with 
a Mixer” on page 66.

3. If you are using the signal generator with a spectrum analyzer, see “Signal Loss While Working 
with a Spectrum Analyzer” on page 68.

The Power Supply has Shut Down

If the power supply is not working, it requires repair or replacement. There is no user- replaceable 
power supply fuse. Refer to the E8663B Analog Signal Generator Service Guide for instructions.

Signal Loss While Working with a Mixer

If you experience signal loss at the signal generator’s RF output during low- amplitude coupled 
operation with a mixer, you can solve the problem by adding attenuation and increasing the RF 
output amplitude of the signal generator.

Figure 5- 1 shows a hypothetical configuration in which the signal generator provides a low amplitude 
signal to a mixer.
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Figure 5-1 Effects of Reverse Power on ALC

The internally leveled signal generator RF output (and ALC level) is - 8 dBm. The mixer is driven 
with an LO of +10 dBm and has an LO- to- RF isolation of 15 dB. The resulting LO feedthrough of 
- 5 dBm enters the signal generator’s RF output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. 
Since the detector responds to its total input power regardless of frequency, this excess energy causes 
the ALC to reduce the RF output of the signal generator. In this example, the reverse power across 
the detector is actually greater than the ALC level, which may result in loss of signal at the RF 
output.

Figure 5- 2 on page 68 shows a similar configuration with the addition of a 10 dB attenuator 
connected between the RF output of the signal generator and the input of the mixer. The signal 
generator’s ALC level is increased to +2 dBm and transmitted through a 10 dB attenuator to achieve 
the required - 8 dBm amplitude at the mixer input. 
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Figure 5-2 Reverse Power Solution

Compared to the original configuration, the ALC level is 10 dB higher while the attenuator reduces 
the LO feedthrough (and the RF output of the signal generator) by 10 dB. Using the attenuated 
configuration, the detector is exposed to a +2 dBm desired signal versus the - 15 dBm undesired LO 
feedthrough. This 17 dB difference between desired and undesired energy results in a maximum 
0.1 dB shift in the signal generator’s RF output level.

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the signal generator’s RF output when the 
signal generator is used with a spectrum analyzer that does not have preselection capability.

Some spectrum analyzers have as much as +5 dBm LO feedthrough at their RF input port at some 
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than 
the ALC bandwidth, the LO’s reverse power can cause amplitude modulation of the signal generator’s 
RF output. The rate of the undesired AM equals the difference in frequency between the spectrum 
analyzer’s LO feedthrough and the RF carrier of the signal generator.

Reverse power problems can be solved by using one of two unleveled operating modes: ALC off or 
power search.

Setting ALC Off Mode

ALC off mode deactivates the automatic leveling circuitry prior to the signal generator’s RF output. 
In this mode, a power meter is required to measure the output of the signal generator and assist in 
achieving the required output power at the point of detection. 

Use the following steps to set the signal generator to the ALC off mode:

1. Preset the signal generator: press Preset.
2. Set the desired frequency: press Frequency and enter the desired frequency.
3. Set the desired amplitude: press Amplitude and enter the desired amplitude.
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4. Turn the RF off: set RF On/Off to On.
5. Turn the signal generator’s automatic leveling control (ALC) off: press Amplitude > ALC Off On to Off.
6. Monitor the RF output amplitude as measured by the power meter.
7. Press Amplitude and adjust the signal generator’s RF output amplitude until the desired power is 

measured by the power meter.

Setting Power Search Mode

Power search mode executes a power search routine that temporarily activates the ALC, calibrates the 
power of the current RF output, and then disconnects the ALC circuitry. See the E8663B Analog 
Signal Generator Key Reference for more information on the Power Search function. 

Use the following steps to set the signal generator to manual fixed power search mode:

1. Preset the signal generator: press Preset.
2. Set the desired frequency: press Frequency and enter the desired frequency.
3. Set the desired amplitude: press Amplitude and enter the desired amplitude.
4. Turn the signal generator’s automatic leveling control (ALC) off: press Amplitude > ALC Off On to Off.
5. Turn the RF on: set RF On/Off to On.
6. Press Do Power Search.

This executes the manual fixed power search routine, which is the default mode.

There are three power search modes: manual, automatic, and span.

When Power Search is set to Manual, pressing Do Power Search executes the power search calibration 
routine for the current RF frequency and amplitude. In this mode, if there is a change in RF 
frequency or amplitude, you will need to press Do Power Search again.

When Power Search is set to Auto, the calibration routine is executed whenever the frequency or 
amplitude of the RF output is changed.

When Power Search is set to Span, pressing Do Power Search executes the power search calibration routine 
over a selected range of frequencies at one time. The power search corrections are then stored and 
used whenever the signal generator is tuned within the selected range of frequencies.

No Modulation at the RF Output
Check the MOD ON/OFF annunciator on the display. If it reads MOD OFF, press Mod On/Off to toggle the 
modulation on. 

Although you can set up and enable various modulations, the RF carrier is modulated only when you 
have also set Mod On/Off to On.
Agilent E8663B Analog Signal Generator User’s Guide 69



Troubleshooting
Sweep Problems
Sweep Problems

Sweep Appears to be Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar. You can 
observe the progress bar to determine if the sweep is progressing. If the sweep appears to have 
stalled, check the following:

❏ Have you turned on the sweep by pressing any of the following key sequences?

  Sweep/List > Sweep > Freq

  Sweep/List > Sweep > Ampl

  Sweep/List > Sweep > Freq & Ampl

❏ Is the sweep in continuous mode? If the sweep is in single mode, be sure that you have pressed 
the Single Sweep softkey at least once since completion of the prior sweep. Try setting the mode to 
continuous to determine if the missing single sweep is blocking the sweep.

❏ Is the signal generator receiving the appropriate sweep trigger? Try setting the
Sweep Trigger softkey to Free Run to determine if a missing sweep trigger is blocking the sweep.

❏ Is the signal generator receiving the appropriate point trigger? Try setting the Point Trigger softkey 
to Free Run to determine if a missing point trigger is blocking the sweep.

❏ Is the dwell time appropriate? Try setting the dwell time to one second to determine if the dwell 
time was set to a value which was too slow or too fast for you to see.

❏ Do you have at least two points in your step sweep or list sweep?

Cannot Turn Off Sweep Mode

Press Sweep/List > Sweep > Off.

In the sweep mode menu you can choose to set the sweep to various sweep types or to turn sweep 
off.

Incorrect List Sweep Dwell Time

If the signal generator does not dwell for the correct period of time at each sweep list point, follow 
these steps:

1. Press Sweep/List > Configure List Sweep.

This displays the sweep list values.

2. Check the sweep list dwell values for accuracy.

3. Edit the dwell values if they are incorrect.

NOTE The effective dwell time at the RF OUTPUT connector is the sum of the value set for the 
dwell plus processing time, switching time, and settling time. This additional time added to 
the dwell is generally a few milliseconds. The TTL/CMOS output available at the TRIG OUT 
connector, however, is asserted high only during the actual dwell time.

If the list dwell values are correct, continue to the next step.
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4. Observe if the Dwell Type List Step softkey is set to Step.

When Step is selected, the signal generator will sweep the list points using the dwell time set for 
step sweep rather than the sweep list dwell values.

To view the step sweep dwell time, follow these steps:

a. Press Configure Step Sweep.

b. Observe the value set for the Step Dwell softkey.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. 
Only the current list sweep is available to the signal generator. List sweep data can be stored in the 
instrument catalog. For instructions, see “Storing Files to the Memory Catalog” on page 33.

Data Storage Problems

Registers With Previously Stored Instrument States are Empty

The save/recall registers are backed- up by a battery when line power to the signal generator is not 
connected. The battery may need to be replaced. 

To verify that the battery has failed:

1. Turn off line power to the signal generator.

2. Unplug the signal generator from line power.

3. Plug in the signal generator.

4. Turn on the signal generator.

5. Observe the display for error messages.

If either error message −311 or −700 is stored in the error message queue, the signal generator’s 
battery has failed. 

6. Refer to the E8663B Analog Signal Generator Service Guide for battery replacement instructions.

Saved Instrument State, but Register is Empty or Contains Wrong State

If you select a register number greater than 99, the signal generator automatically selects register 99 
to save the instrument state.

If the register number you intended to use is empty or contains the wrong instrument state, recall 
register 99:

Press Recall > 99 > Enter.

The lost instrument state may be saved there.
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Cannot Turn Off Help Mode
1. Press Utility > Instrument Info/Help Mode 

2. Press Help Mode Single Cont until Single is highlighted.

The signal generator has two help modes; single and continuous. 

When you press Help in single mode (the factory preset condition), help text is provided for the next 
key you press. Pressing another key will exit the help mode and activate the key’s function.

When you press Help in continuous mode, help text is provided for the next key you press and that 
key’s function is also activated (except for Preset). You will stay in help mode until you press Help 
again or change to single mode.

Signal Generator Locks Up
If the signal generator is locked up, check the following:

• Make sure that the signal generator is not in remote mode (in remote mode, the R annunciator 
appears on the display). To exit remote mode and unlock the front panel keypad, press Local.

• Make sure that the signal generator is not in local lockout condition. Local lockout prevents front 
panel operation. For more information on local lockout, refer to the E8663B Analog Signal 
Generator Programming Guide.

• Check for a progress bar on the signal generator display, which indicates that an operation is in 
progress.

• Press Preset.

• Cycle power on the signal generator.

Fail-Safe Recovery Sequence

Use the fail- safe recovery sequence only if the previous suggestions do not resolve the problem. 

CAUTION This process does reset the signal generator, but it also destroys the following types of 
data:

• all user files (instrument state and data files) 
• DCFM/DCΦM calibration data
• persistent states

NOTE Do not attempt to perform any other front panel or remote operations during the fail- safe 
sequence. 

To run the fail- safe sequence, follow these steps:

1. Hold down the Preset key while cycling power. 

2. Continue to hold down the Preset key until the following message is displayed:

WARNING You are entering the diagnostics menu which can cause unpredictable instrument 
behavior. Are you sure you want to continue?
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CAUTION Carefully read the entire message! It may list additional risks with this procedure.

3. Release the Preset key.

4. To continue with the sequence, press Continue (to abort with no lost files, press Abort).

5. When the sequence concludes, do the following:

a. Cycle power. 

Cycling power restores all previously installed options. Because calibration files are restored 
from EEPROM, you should see several error messages.

b. Perform the DCFM/DCΦM calibration. 

Refer to the DCFM/DCΦM Cal softkey description in the E8663B Analog Signal Generator Key 
Reference.

c. Agilent Technologies is interested in the circumstances that made it necessary for you to 
initiate this procedure. Please contact us at the telephone number listed at 
http://www.agilent.com/find/assist. We would like to help you eliminate any repeat 
occurrences.

Error Messages
If an error condition occurs in the signal generator, it is reported to both the front panel display 
error queue and the SCPI (remote interface) error queue. These two queues are viewed and managed 
separately; for information on the SCPI error queue, refer to the E8663B Analog Signal Generator 
Programming Guide.

NOTE When there is an unviewed message in the front panel error queue, the ERR annunciator 
appears on the signal generator’s display.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Circular (rotating).
Drops oldest error as new error comes in.

Viewing Entries Press: Utility > Error Info > View Next (or Previous) Error Page

Clearing the Queue Press: Utility > Error Info > Clear Error Queue(s)

Unresolved Errorsa

a.Errors that must be resolved. For example, unlock.

Re- reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue:
0 No Error Message(s) in Queue
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Error Message File

A complete list of error messages is provided in the file errormessages.pdf, on the CDROM supplied 
with your instrument.

In the error message list, an explanation is generally included with each error to further clarify its 
meaning. The error messages are listed numerically. In cases where there are multiple listings for the 
same error number, the messages are in alphabetical order. 

Error Message Format

When accessing error messages through the front panel display error queue, the error numbers, 
messages and descriptions are displayed on an enumerated (“1 of N”) basis.

Error messages appear in the lower- left corner of the display as they occur.

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query 
error will not generate a device- specific, execution, or command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue control has detected a 
problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this class 
set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors 
correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

• Either an attempt is being made to read data from the output queue when no output is either 
present or pending, or

• data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate that a device operation 
did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes 
are also used for self- test response errors. Errors in this class set the device- specific error bit (bit 3) 
in the event status register (IEEE 488.2, section 11.5.1).

Explanation provided in the Error Message List
(This is not displayed on the instrument)
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The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that 
the instrument detected an error within the GPIB system, within the instrument’s firmware or 
hardware, during the transfer of block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by the instrument’s 
execution control block. Errors in this class set the execution error bit (bit 4) in the event status 
register (IEEE 488.2, section 11.5.1). In this case:

• Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of 
its legal input range or is otherwise inconsistent with the device’s capabilities, or

• a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. 
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser detected an IEEE 488.2 
syntax error. Errors in this class set the command error bit (bit 5) in the event status register 
(IEEE 488.2, section 11.5.1). In this case:

• Either an IEEE 488.2 syntax error has been detected by the parser (a control- to- device message 
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data 
element that violates device listening formats or whose type is unacceptable to the device.), or

• an unrecognized header was received. These include incorrect device- specific headers and 
incorrect or unimplemented IEEE 488.2 common commands.

Contacting Agilent Sales and Service Offices
Assistance with test and measurement needs, and information on finding a local Agilent office are 
available on the Internet at:
http://www.agilent.com/find/assist

You can also purchase signal generator accessories or documentation items on the Internet at: 
http://www.agilent.com/find/e8663b

If you do not have access to the Internet, contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model 
number and full serial number. With this information, the Agilent representative can 
determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent Technologies
To return your signal generator to Agilent Technologies for servicing, follow these steps:

1. Gather as much information as possible regarding the signal generator’s problem. 

2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific 
to your geographic location. If you do not have access to the Internet, contact your field engineer. 

After sharing information regarding the signal generator and its condition, you will receive 
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar 
packaging to properly protect the signal generator.
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Symbols
ΦM, 12, 61

Numerics
10 MHz connectors, 17, 18
1EM, option, 2
802.11b, 47

A
AC power receptacle, 17, 18
active entry area (display), 11
adding & editing (instrument state), 35
adjustments, display, 9
Agilent web page

additional information, 1
ALC

annunciator, 12
bandwidth selection, 47
input connector, 8
input connector (rear), 20
limitations, amplitude, 49
off mode, setting, 68
with attenuator option, 48

AM, 12, 60
amplitude

display area, 14
hardkey, 6
LF output, 64
modulation. See AM
reference & offset, 26

analog
optional features

optional features, 2
analog modulation, 4, 59–64
annunciators, 12
application notes

obtaining, 1
ARMED annunciator, 12
arrow hardkeys, 9
ATTEN HOLD annunciator, 12
attenuator, external leveling, 48
automatic leveling control. See ALC
AUXILIARY INTERFACE connector, 17

B
bandwidth

ALC, selecting, 47
reference oscillator, adjusting, 56

basic operation
standard, 21

binary files, 32
bit files, 32
bursted signals, 47

C
carrier signal, modulating, 31
CDMA, 47
certificate, license key, 41
comments, adding & editing (instrument state), 35
confidential data, 36
connectors

front panel, 5
rear panel, 15

continuous
list sweep, 30
step sweep, 28

continuous wave
configuring, 24
description, 4

contrast adjustments (display), 9
correction array (user flatness)

configuration, 53
load from step array, 54
viewing, 54
See also user flatness correction

couplers/splitters, using, 48
CW mode

configuring, 24
description, 4

D
data

fields, editing, 23
files, 32
input methods, 36
removal, 38
sensitive, 36, 38
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data (continued)

storage
problems, 71
security, 36
See also instrument state register
See also memory catalog

data sheets, 1
DC offset, 61
declassification, 36
Delete Item softkey, 23
Delete Row softkey, 23
description, adding & editing (instrument state), 35
detector

diode response, 49
using, 48

DHCP, 42
diode detector response, 49
display

blanking, 40
contrast decrease, 9
contrast increase, 9
descriptions, 11
overview, 11
secure, 40

DMOD files, 32
documentation, ix
documentation options, 3
downloading firmware, 3
dwell time, 27

E
Edit Item softkey, 23
Erase All, 38, 39, 40
erase and overwrite, 38
erase and sanitize, 38
erasing memory, 36, 38, 39, 40
ERR annunciator, 12, 73
error messages

display, 14
message format, 74
overview, 73
queue, 73
types, 74

EXT
annunciators, 12

EXT (continued)
INPUT connectors, 7
input connectors, 7
input connectors (rear), 19

external
detector, diode response, 49

external FM, 61

F
fail-safe recovery sequence, 72
failures. See troubleshooting
FAQ, 1
features, signal generator, 1
file store
files, 34

catalogs, 32
using, 33
See also instrument state register
See also memory catalog

FIR, 32
firmware

options, 3
upgrades

obtaining, 3
using GPIB, 3
using LAN, 3
using RS-232, 3

flatness correction. See user flatness correction
FM, 12, 60
FM/ΦM hardkey, 7
frequency

display area, 12
hardkey, 6
modulation. See FM
offset, 25
ranges, 1
reference, 25
RF output, setting, 24

front panel
description, 5–11
disabling keys, 40
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G
GATE/PULSE/TRIGGER

input connector, 9
input connector (rear), 20

gated, 62
Goto Row softkey, 23
GPIB, 17, 56
guides, ix

H
hardkeys, 5–10
Help hardkey, 7
help mode troubleshooting, 72
Hold hardkey, 9

I
Incr Set hardkey, 9
information

additional, 1
protecting sensitive, 36

Insert Item softkey, 23
Insert Row softkey, 23
installation guide, ix
installing firmware, 3
instrument state register

comments, adding and editing, 35
troubleshooting, 71
using, 34
See also memory catalog

int gated, 62
interface connectors

AUXILIARY INTERFACE, 17
GPIB, 17
LAN, 18
RS-232, 17

interface, remote, 56

K
key, license, 41
keypad, numeric, 8
keys

disabling, 40
front panel, 5–10

knob, front panel, 6

L
L (listener mode) annunciator, 13
lan configuration, 42
LAN connector, 18
LEDs, 10
leveling

ALC, 8, 68
external, 48–51
internal, 47

LF OUT connector, 19
LF output, 8, 63–64
license key, 41
line power LED, 10
list

error messages, 74
files, 32
mode values table editor, 22
sweep, 28, 70

listener mode annunciator, 13
Load/Store softkey, 23
Local hardkey, 9
low frequency output. See LF output

M
MDMOD files, 32
media storage, 36
memory

base instrument, 36
baseband generator, 36
catalog, 32, 71

See also instrument state register
erasing, 36, 38
hard disk, 36
overwriting, 38
persistence, 36
physical location, 36
sanitizing, 38
secure mode, 39
size, 36
types, 36
waveform, 36
writing to, 36

MENUS hardkeys, 7
mixer, signal loss while using, 66
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mod on/off, 8, 13
models, signal generator, 1
modes of operation, 4
modulation

amplitude. See AM
analog, 4, 59–64
analog waveforms, 59
annunciators, 12
applying, 31
file catalogs, 32
frequency. See FM
on/off hardkey, 8
phase. See ΦM
pulse, 4, 62
See also digital modulation

MTONE files, 32

N
numeric keypad, 8
NVMKR files, 32
NVWFM files, 32

O
OFDM, 47
offset, 25, 26, 61
on/off switch, 10
operation

basics, 21
modes of operation, 4

options
1EM, 2
additional information, 3
enabling, 41
UNW, 2, 4, 59, 62

oscillator, reference, adjusting BW, 56
output power, troubleshooting, 66
output. See LF output and RF output
OVEN COLD annunciator, 13
overwriting memory, 38

P
Page Down softkey, 23
Page Up softkey, 23
performance, optimizing, 47–57

phase
modulation. See ΦM

power
meter, 52, 68
output, troubleshooting, 66
receptacle, AC, 17, 18
search mode, 69
supply troubleshooting, 66
switch, 10

Preset hardkey, 10
private data, 36
problems. See troubleshooting
product information, 1
programming

guide, ix
proprietary data, 36
protecting data, 36
pulse, 47

annunciator, 13
input, 9
input (rear), 20
modulation, 62

pulse modulation, 4
pulse source, 62
PULSE SYNC OUT, 19
PULSE VIDEO OUT, 20
PULSE/TRIG GATE INPUT, 20

Q
queue, error, 73

R
R (remote) annunciator, 13
rear panel description, 15
Recall hardkey, 6
recall states, 34
recovery sequence, fail-safe, 72
reference

amplitude, setting, 26
frequency, setting, 25
oscillator bandwidth, adjusting, 56

references, ix
registers, 34, 35
remote operation, 7, 56
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remote operation annunciator, 13
restricted data, 36
Return hardkey, 9
returning a signal generator, 75
RF blanking, 65
RF output

annunciator, 13
configuring, 24
connector, 8
connector (rear), 19
leveling, external, 48–51
On/Off hardkey, 8
sweeping, 26
troubleshooting, 65
user flatness correction, 51–56

RS-232 connector, 17

S
S (service request) annunciator, 13
sanitizing memory, 38
save and recall states, 34
save files
Save hardkey, 6
SCPI, 42

reference, ix
SCPI commands, 7
secure display, 40
secure mode, 39
security functions, 36, 39
security level, 39
sensitive data, 36
Seq files, 32
sequences

deleting, 35
instrument state register, 34

service guide, ix
service request annunciator, 13
service, Agilent sales and service offices, 75
shape files, 32
signal generator

features, 1
firmware

firmware, 3
models, 1
modes, 4

signal generator (continued)
options

options, 3
overview, 1

signal loss, troubleshooting, 65
single step sweep, 27
softkeys, 6, 14, 23
software

available, 1
options, 3

SOURCE SETTLED OUTPUT connector, 19
spectrum analyzer, troubleshooting signal loss, 68
standby LED, 10
state files, 32
step array (user flatness), 52

See also user flatness correction
step attenuator, external leveling, 48
step sweep, 27–28
storage, troubleshooting, 71
sweep

annunciator, 13
list, 28
mode, 4
output, 18
RF output, 26
step, 27
trigger, 30
troubleshooting, 70

sweep progress bar, 26
Sweep/List hardkey, 7
switch, power, 10
SYNC OUT connector, 8
SYNC OUT connector (rear), 19

T
T (talker mode) annunciator, 13
table editor, using, 22–23
talker mode annunciator, 13
TCP/IP, 42
technical support, 1
text display area, 14
trigger

hardkey, 6
inputs

GATE/PULSE/TRIGGER, 9
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trigger (continued)

inputs
GATE/PULSE/TRIGGER (rear), 20
TRIGGER IN, 19

output, 19
setting, 30

trigger in, 62
trigger polarity, 62
troubleshooting, 65–75

U
UNLEVEL annunciator, 14
UNLOCK annunciator, 14
UNW, option, 2, 4, 59, 62
upgrading firmware, 3
user documentation, ix
user flatness, 32, 51–56
user-defined

files, 32

V
VIDEO OUT connector, 9
VIDEO OUT connector (rear), 20

W
waveform memory, 36
waveforms

analog modulation, 59
file catalogs, 32

web server, 42
website

web page, 1
WFM1 files, 32
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